1

I'm experimenting with podman under NetBSD and want to mount a host directory into the container.

  • According to this answer I did:
    podman machine init -v ~/podman/volumes/:/mnt/podman tpvm
    podman machine start tpvm
    
  • Now I would expect that
    podman machine ssh tpvm 'ls /mnt'
    
    shows me the podman directory, but it did not.
  • I continue with:
    podman run -ti --rm -v ~/podman/volumes/:/mnt/podman busybox
    
    and I get:
    Error: statfs /home/thomas/podman/volumes: no such file or directory
    
  • However:
    ll  /home/thomas/podman/volumes
    total 1.5K
    drwxr-xr-x  3 thomas  users  512B Nov 16 16:20 .
    drwxr-xr-x  4 thomas  users  512B Nov 16 16:20 ..
    drwxr-xr-x  2 thomas  users  512B Nov 17 15:56 posgres
    

There is a MAC related thread here, and I also tried this idea but always get the same error.

Any ideas what went wrong?

P.S.: I also checked the output of --log-level=debug of the above commands, but got nothing useful for this case.

0

You must log in to answer this question.

Browse other questions tagged .