0

I try to set up windows+linux on lenvo p50. Installation:

  1. windows installation, installer also made 100mb efi partition
  2. ubuntu installation, same disk

After that I would like to choose boot from "Windows Boot Loader" and "Ubuntu/Grub". However from the uefi I can only choose "Windows Boot Loader".

To overcome this I tried:

Did I made correct assumption that uefi can have both grub and windows boot loader entries to choose? Did anyone had similar problem?

11
  • Chances are your UEFI firmware is bugged that boot entry cannot be added "manually" (as opposed to "discovered"; i.e., relying on standard and Windows-specific fallback path). Are you sure that you have installed Ubuntu in UEFI mode though? Check whether there's e.g. an ubuntu directory under /EFI of the EFI partition, assuming you only have one on that drive.
    – Tom Yan
    Commented Nov 15, 2023 at 15:35
  • @TomYan I've got ubuntu dir in /EFI Commented Nov 15, 2023 at 15:57
  • Lets see details: Please copy & paste the pastebin link to the BootInfo summary report ( do not post report), do not run the auto fix till reviewed. Use often updated ppa version over somewhat older ISO with your USB installer or any working install. help.ubuntu.com/community/Boot-Repair & sourceforge.net/p/boot-repair/home/Home Can you manually add entry from UEFI settings? askubuntu.com/questions/1492536/…
    – oldfred
    Commented Nov 15, 2023 at 16:09
  • So have you checked whether your attempts of creating a boot entry has any persistent effect? I mean like do you see any new entry listed by efibootmgr right after your attempt, and also, whether the new entry vanish after a reboot?
    – Tom Yan
    Commented Nov 15, 2023 at 16:10
  • @TomYan they actualy do not vanish, however the boot order does not work and added entries to efibootmgr do not appear in UEFI menu Commented Nov 15, 2023 at 17:04

1 Answer 1

0

Finally I reset the BIOS to default settings (and changed default legacy+uefi to uefi only boot) and finally all boot options listed by efibootmgr and bcdedit finally appeared as boot options at startup. After that I realised that there is "Boot Order Lock" option in UEFI BIOS - I don't know if it was enabled or disabled beforehand - I am pretty sure that I had checked all UEFI boot options (Secure boot, etc...) Anyway, everything is working fine now. Thank you all for very helpful advises!

One thing I am curious about - is it possible to add linux/grub option to windows boot manager - I tried this solution as aworkaround but it didn't work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .