7

I was trying to install ia32-libs in Debian Wheezy. I got the error

The following packages have unmet dependencies:
 ia32-libs : Depends: ia32-libs-i386 but it is not installable
E: Unable to correct problems, you have held broken packages.

I am using

# uname -a
Linux debian 3.2.0-4-amd64 #1 SMP Debian 3.2.41-2 x86_64 GNU/Linux

My sources.lst is

# cat /etc/apt/sources.list
# 

# deb cdrom:[Debian GNU/Linux 7.0.0 _Wheezy_ - Official amd64 DVD Binary-1 20130504-14:44]/ wheezy contrib main

# deb cdrom:[Debian GNU/Linux 7.0.0 _Wheezy_ - Official amd64 DVD Binary-1 20130504-14:44]/ wheezy contrib main

deb http://security.debian.org/ wheezy/updates main contrib
deb-src ftp://ftp.iitm.ac.in/debian/ wheezy/updates main contrib

# wheezy-updates, previously known as 'volatile'
# A network mirror was not selected during install.  The following entries
# are provided as examples, but you should amend them as appropriate
# for your mirror of choice.
#
deb http://ftp.debian.org/debian/ wheezy-updates main contrib
deb http://http.us.debian.org/debian/ wheezy contrib non-free main
# deb-src http://ftp.debian.org/debian/ wheezy-updates main contrib
deb http://ftp.us.debian.org/debian stable main contrib non-free
deb http://security.debian.org/ wheezy/updates main contrib non-free

1 Answer 1

16

Since Wheezy introduces multiarch, the ia32-libs package in now deprecated. It is now possible to install 32bit packages directly:

dpkg --add-architecture i386 # enable multi-arch
apt-get update
apt-get install libc6:i386 # install base 32bit libraries

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .