0

I am trying to use tmux on Kali linux and I maximize my terminal size. When I start tmux with the following command the pane does not fit to the terminal size: tmux new -s session As seen in the screenshot below it leaves out a huge chunk of the terminal width. This makes it not usable for me, especially if I want to split the window into multiple panes.

tmux pane size issue

I created a .tmux.conf with the following lines in my homedir. But it doesn't change anything.

set -g window-size latest
set-window-option -g aggressive-resize on
set -g window-status-current-style bg=black,fg=red
set -g base-index 1
set -g mouse on

I also tried to run the command <c-b>:resize-window -A mentioned in one other thread here. But to no avail. I did check the other threads here mentioning seemingly similar issues. But I couldn't find anything that helped.

The tmux version in use is version 3.3.

Does anyone know how to fix this issue?

Based on the answer In checked the following: Both vi and top do not use the whole terminal width as well. But what bothers me, I just use the Kali default. I didn't change anything there from the default installation. Therefore the terminal emulator defaults to qterminal. If I check $TERM it states xterm-256color.

I tried to switch to the Debian default terminal via Kali's system settings. But the problem remains with that terminal emulator as well.

I also set a fixed width for the terminal via its own settings to 1000px. Doesn't change a thing either. As for the font it says Cantarell 11pt.

1
  • What version of Kali? Also, do you have a high-res monitor? It may be related to high-DPI scaling. You can check your monitor settings or try an alternative terminal program.
    – Matt M
    Commented Nov 1, 2023 at 22:14

1 Answer 1

0

I'm sure your problem is not related to tmux. Try different apps, such as the mc file manager, top, your favorite text editor etc. I'm sure their layout all falls apart in a similar manner.

Based on the screenshot, you are using a variable width font, combined with a terminal emulator that just prints each row's characters one after the other without aligning them to the grid.

Terminals are supposed to have a strict grid of character cells. You should choose a fixed width font, and/or you should use a terminal emulator that sticks the characters to the grid even if they happen to vary in width. Preferably both.

(Just for curiosity: which graphical terminal emulator is it?)

1
  • I checked the Kali settings and it defaults to qterminal. If I check $TERM is states xterm-256color.
    – JC_D
    Commented Nov 2, 2023 at 5:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .