4

I am trying to install a Debian package, but it gives error as "sudo: dpkg: command not found". I installed SUDO, and it still giving the same error. I went to the dir where .deb is saved, and ran command as

sudo dkpg -i file.deb

I tried installing the debian support package from "http://packages.debian.org/wheezy/all/dpkg-dev/download", but these files also are in .deb format, so I am unable to install this.

Any suggestions...

  • 5
    "dpkg: command not found" - it means that there is no dpkg command not sudo command. What distro are you using? Is it really Debian? What version? How you installed sudo? – pbm May 16 '13 at 5:39
  • 4
    You are misspelling dpkg in your example command. Are you aware of that? – daniel kullmann May 16 '13 at 8:36
  • Can you post the output of lsb_release -a? – Flup May 16 '13 at 9:37
7

As pointed out in the comments, if that's an exact quote of what you're typing to try to install it you're making a typo:

sudo dkpg -i file.deb

won't work, but

sudo dpkg -i file.deb

will.

Spelling is not optional when it comes to the command line.

3

Try them :

Method 1)
Right-click on the *deb file, and open it with gdebi. This will install any needed dependencies for you.

Method 2)
You need to specify where is the file is. E.g.:

sudo dpkg -i Desktop/install_flash_player_10_linux.deb

Method 3)
The error can also occur when your shell cannot find sudo.

-bash: sudo: command not found

Almost certainly, sudo needs to be installed. Login as root and run:

# apt-get install sudo

An error is also given when you are trying to install many debian files simultaneously.
First let one file install completely through Software center and then try using the command.

  • Method 2): if dpkg cannot be found, specifying the full path will not help at all. Method 3): the OP already tried that. – Anthon May 16 '13 at 7:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.