0

I recently purchased a HP 14-fq1003cl laptop and stripped it curse that is Windows 11 and put KDE neon on the system. It works very well with Linux and I am very pleased with it.

However, one issue that I've encountered numerous times with it is when I resume it from sleep, the clock jumps forward sometimes. Normally it only happens when I have the laptop plugged into power, closing the lid (triggering sleep), unplugging it while still suspended, and resuming after leaving it suspended for more than a few minutes. Other times just a simple suspend and resume is all it takes to trigger this. If it helps at all, it likes jumping ahead to the years 2077 or 2195.

I can fix it by simply disabling NTP and re-enabling it, and I've even gotten so frustrated that I created a keybind to fix it quickly.

I have dug around in numerous articles from the Unix StackExchange, AskUbuntu, etc. and found no solution short of "Don't suspend your system, just shut it down". And while I'd prefer not to use that as the best solution, I will take it over no solution at all. But I would like to at least figure out what the hell is going on before giving up and taking that as my final solution.

1 Answer 1

0

Turns out checking the date and time in the BIOS would be beneficial, when running timedatectl status I learned that the RTC really did report the year 2077. Installing chrony and properly setting the RTC solved the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .