1

Guess this is the first time I post a question here. Have been playing with Linux and VMware servers for more than 10 years now. Lately I decided to move my focus on Debian desktops and ProxMox (again). Reasons being more privacy friendly, broader hardware support and lower resource reqs. So bye bye Windows (for now) and Intel/AMD (later on). Have been working hard to compose my own Debian desktop from scratch, picking XFCe for GUI. Works quite nice now (not as slick as Windows, but smarter, faster), but with a lot of loose ends to tie up. One of em being the lack of genuine Microsoft fonts (working on that), another being Samba on my (home brew) NASses: gives a number of issues with Linux applications (locking problems, not able to create shortcuts on the NAS, etc). Will try and see how NFS goes later.

My problem, however: Having converted my 1st Windows desktop to a Debian/XFCe desktop I am about to convert my 2nd Windows desktop. I've used Clonezilla v2.2.3 for years and it served me well. When trying to backup Debian v11 (Bullseye) though, it didn't work so well. Had to upgrade to Clonezilla v3.0.1. Now for the cloning part: my three Windows desktops have identical hardware, and cloning Windows (with Clz v2.2.3) always went well (of course changing licence keys, IPs and hostnames). But when I clone my Debian desktop (with disk-to-image backup and image-to-disk restore), I can't make the clone to boot. BIOS/UEFI says 'Reboot and select proper boot device'. Tried to fix it myself. Read a number of posts (many ArchLinux and Ubuntu by the way) and finally tried this: www.debian.org/releases/stable/amd64/ch08s06.en.html

Using my Debian installation USB stick I was able to get into Rescue Mode and have the installer reinstall GRUB on my boot disk: it ended with: "Execution of 'grub-install /dev/sda' failed". Most of the other articles I read point in the same direction, so I'm kinda stuck.

My questions: Does anybody have good experiences with cloning Linux systems with Clonezilla? Any idea how I could go on from here?

Additional info: My partiton layout is:

    #      Size    In use      Free      iSize   Type/description
    1    499 MB      4 MB    495 MB    476 MiB   EFI/boot partition (/boot/efi)
    2   40,0 GB   11,8 GB   28,2 GB   37,3 GiB   Linux root (/)
    3   16,1 GB   10,0 GB     PM       9,3 GiB   Linux swap
    4   70,0 GB   12,3 GB   57,7 GB   65,2 GiB   Linux home (/home)
    -    120 GB     PM       120 GB  111,3 GiB   Free space

1st partition starts at sector 2048 (partition alignment is at 1 MB intervals). Sector 0 = boot sector, sector 2-33 is (primary?) GPT partition table. Don't know what sector 1 is used for.

Wikipedia says GPT is GUID (UUID) based. I'm aware that with GPT every disk (and partition on it) has a UUID. Can't remember if I had to fix that when cloning Windows in the past. On the other hand: overriding a UUID during cloning to me seems only a possible problem if the old UUID is actually stored in NVRAM in the BIOS/UEFI. I've not seen an indication for this in my (AMI) BIOS boot menu. On my live desktop I see a directory called 'EFI' under '/boot/efi'. The latter directory was empty when I looked at it on my clone system under Rescue Mode. But I guess that's OK since I learned that my 1st partition is mounted under /boot/efi during normal bootup.

Final remarks: I've searched through this forum and found slightly related posts, but not close enough. And I hope my personal introduction is not considered too long or off topic.

Awaiting your reactions, With kind regards,

Steijn van Essen

From i8088 to i7-980X in 25 years and still waiting … But not for much longer: when Windows is gone, Intel will be next (in favor of ARM on Raspberry Pi)

8
  • Maybe you can add the output of lsblk and your /etc/fstab. The EFI partition needs to be mounted when you do grub-install.
    – ctx
    Commented Oct 27, 2023 at 14:24
  • My answer to your question: 'Does anybody have good experiences with cloning Linux systems with Clonezilla?' is yes I have - My tips: 1. Is the target drive at least as big as the source drive, not one single byte smaller? 2. Maybe it would help to repair the backup partition table of the GPT with gdisk (if you have GPT); 3. Maybe there is some bad setting in the UEFI/BIOS system. Please compare the UEFI/BIOS menus of the working computer with those with cloned operating system.
    – sudodus
    Commented Oct 27, 2023 at 20:05
  • @jsotola: yep, I was already afraid my intro was too long. But since I'm new here I wanted to introduce myself to the forum readers. So I did and won't happen again. Commented Oct 27, 2023 at 21:20
  • @ctx: from which context you would like to see this output: my clone doesn't start up. So it's either from the live system it was cloned from or from my installer's Rescue Mode. Or do you have an other option in mind? Commented Oct 27, 2023 at 21:24
  • 1
    @sudodus: You have good experiences?! Sounds great! Ad 1: the hardware of my three (former) Windows PC's is identical, that includes the SSDs (same brand, model and size). But I could check. If it IS a bit smaller then the backup GPT might not fit or be incomplet/corrupted. I'll check the sector count of both. Ad 2: I'll keep that in mind. Ad 3: I suspect some UEFI/BIOS differences. I already had trouble booting the Debian installer. Worked fine after factory reset of the settings and reconfiguration. I'll try to make the settings on clone BIOS identical to that of live BIOS. Commented Oct 27, 2023 at 21:40

1 Answer 1

1

You all provided help to me and I decided to go with a quick win first: checking my BIOS setup. Found a number of differences and ended up with aligning the settings on both the source and the clone systems. No need to do another Clonezilla backup/restore after that, because my clone came gradually alive:

  • somehow 'boot mode' was set back to 'legacy' on the clone
  • as a result of this it was still looking for Windows Boot Manager
  • changed 'legacy' to 'UEFI' and saved and rebooted
  • now an additional boot option entry was added to my BIOS screen
  • this option was called 'EUFI HDD BBS priorities'
  • in this submenu I saw this boot order: #1 Windows Boot Manager #2 Windows Boot Manager #3 debian (P1: OCZ ARC100)
  • I changed the entries as follows: #1 debian (P1: OCZ ARC100) #2 disabled #3 disabled
  • after save and restart my clone Linux system booted flawless
  • problem solved!

@ctx: My /boot/efi is now mounted. @jsotola: I realized later that introducing myself can be done in my forum profile. I will add some personal info there. @ sudodus: Thanx for the golden tip. My system is a Shuttle DH110 (2016). I have three of them (and one defect/spare). My other systems are 2 x Shuttle DS57 (2015) and 4 x Shuttle DS81 (2014). None of them are supported by Windows 11, hence my move to Linux.

Once more: thank you all for your help!

1
  • Congratulations and thanks for sharing your solution :-)
    – sudodus
    Commented Nov 3, 2023 at 15:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .