1

I have:

I am new to Ubuntu (or Wayland?) and have an issue with two different ways to switch keyboard layout.

  • Ubuntu 22.04.3 LTS
  • Gnome 42.9
  • Windowing system Wayland

And I currently have two different switches for layouts. Here is what I found so far:

Settings application

The Settings application provides just one way to switch layouts, I find this in Settings by going Keyboard -> Keyboard Shortcuts -> Typing. There I have Super+Space for the switch. This works, but...

  1. I'd like to define LeftAlt+LeftShift as a toggle switch, but the settings window does not accept this.
  2. Is it possible to increase size of layout indicator? I have a very big screen and tiny language code in the corner of the screen is not very easy readable. Is there a way (setting somewhere or applet/plugin/extension) to increase font size for the language indicator and/or use country flags to show which language layout is in use?

gsettings

Open terminal, issue command:

gsettings set org.gnome.desktop.input-sources xkb-options "['grp:lalt_lshift_toggle']"

This done exactly what I want, but using this hotkey does not change language indicator on the screen, and I have to type a letter or two to understand which layout is active one.

  1. Is there a way to synchronize the on-screen indicator with that switch?
  2. Is this a different input method from the one controlled by Settings application? (ibus vs xkb?)
  3. The switch of layout does not happen always. Sometimes I need to hit LeftAlt+LeftShift twice (hit it, type letter, backspace, hit it again) to switch the layouts. Completely not sure where to search for a reason for this problem.

So currently ...

I have two switches: Super+Space and LeftAlt+LeftShift... And constantly mix them. I can, of course, remove one, but I have several other computers (under Mint/Cinnamon and Windows) which use LeftAlt+LeftShift, so I would really prefer to stick with this one (finger memory is powerful thing).

So I am not sure which direction I should take at this moment and which method to trust/improve more, the Settings or gsettings? Or install some third application like xkbd-switch or something else? Or go all the way and replace Ubuntu with Mint?

1 Answer 1

0

Eventually, I switched to Cinnamon from Wayland. And completely removed ibus (sudo apt remove ibus*). This does solve all my problems, at least for now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .