I was currently running Win8 and F17 as a dual boot on my home desktop with an i5 chip and Asus UEFI BIOS. Unfortunately, while I was in Win8 I accidentally removed the partition that held my F17 OS.

Now whenever I boot I'm prompted with error: no such partiton. Entering rescue mode... and then the single prompt grub rescue>.

Now I've been searching the web for a solution to this problem, but I haven't found an answer yet. These are some of the methods that I've tried so far:

  1. Burned a Windows 8 Recovery DVD; wasn't recognized
  2. Tried creating a liveusb with F17 i686 desktop version
  3. Followed several different tutorials, using commands like insmod and makeactive but neither are recognized

Currently, I've found a a page in the Fedora Docs about editing the /etc/grub.d/10_linux file.

Is this what I have to do in order to fix this gigantic headache? If so, how do I go about doing this? I know that people have had this problem before; I've just been unable to find the solution myself.

Any help is greatly appreciated.

Edit1: When I tried to boot with the liveUSB, it wasn't recognized. Even though I set my boot priority to be USB first. I was still taken directly to the grub rescure> prompt.



You must log in to answer this question.

Browse other questions tagged .