1

couples of days ago i wanted to upgrade my mint linux by installing a fresh one to a new disk. i then found the last available sata cable's clip was broken so i replaced it. then the story began...

i attached a new disk and turned on my linux but the hdd led light kept flashing. after a while it booted up to my existing linux. i couldnt find my new disk so i shut down my machine and performed some checks. after checking all cables and fixed a loose sata cable i booted it up again (after quite a long time for booting up due to disks failures) and still couldnt find my new disk. what's more was that many of my disks were reported as empty (nothing on disks). i did a df and i could see the disks usage but a ls procuded nothing. i checked with the log and found a lot of problem with the disks and some cpu crashes. one of the disk is actually a intel raid 1 with 2 x 1tb disks containing a lot of kernel source files

i rebooted the machine hoping to run a live iso but unfortunately the disk partition containing the iso could not be read. while still in grub, i realized the hdd led flashes could be a raid recovery actually. so i let it run since i didnt want to lose any files and i didnt want to reboot it coz i dont want any bad blocks since the raid recovery process has started

now it's been the 6th day i believe and the led is still flashing. i started to lose my patient and i have no clue how long it will take on this old machine with a i5 1245v2 processor (some said less than 4 days for a 1tb x2 raid1 without mentioning the cpu) and i remember last time the build process took within a day only when the system booted up. so i am thinking of a way to go inside the system, so that i can try to fix it and at least i can see if it is rebuilding the raid disks actually. i tried to set root in grub but not all partitions can be read, and a ls in grub reported something like

hd0 hd1 hd2(msdos1) hd3(msdos1) hd4 hd5

where hd2 and hd3 should be the raid disks and only hd0's (root partition) contents can be read atm

here are some i can do:

  • boot into single user mode with all disks as ro except root partition
  • boot to recovery mode
  • boot to emergency mode

i don't want to boot with the raid disks as rw as this may interrupt the raid rebuild process, and a ro mount would be disasterous. i dont want to auto mount or mount as rw neither with other disks to avoid further damages. i only want to boot into an environment that can let me try to fix the problems

so my question is, which one should i choose? afaik the emergency wont mount anything but just drop a init shell which may limit what i can do to fix it, while the recovery mode may mount all other disks as rw (i cant remember correctly), and single user mode should not be an option as it will mount all disks as normal

so what should i do? is booting into recovery mode safe? ie no other disks will be mounted?

or is it possible to replace another hdd containing iso files now? although i doubt that even with identical model to swap the existing disks

note that i cant boot by inserting an usb drive now in grub (not detected). the only safe alternative is to copy a live iso to my root and boot it up but it should be impossble under grub.

any suggestion welcomed

regards

1 Answer 1

0

after reading the recovery mode doc from ubuntu, which mentioned something like "other partitions like user/var will not be mounted", and "you have to mount others with mount -all after mounting root as rw", i decided to have a go

the bad news are: i remembered correctly, all disks are mounted automatically....... except one which is probably faulty the good news is: the raid disk has no problem and no rebuilding is shown as per cat /proc/mdstat, so i have no clue why the led kept flashing for a whole week

3
  • So is it working (always was)? Glad for you if you solved your problem.
    – shellter
    Commented Oct 22, 2023 at 21:06
  • yes, but i am not sure if the raid has been rebuilt or not. and, it was not due to a faulty disk which has been used for over 10 yrs. instead it was the old sata cable or sata port on the motherboard (i just plugged a new one to another port). thanks
    – xxjoe
    Commented Oct 23, 2023 at 7:04
  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Commented Oct 27, 2023 at 9:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .