0

Recently, I tried to install Pop! OS on my system over my pre existing Ubuntu 22.04 installation. I have an Acer Nitro 5 with a 256 GB SSD (on which my windows is installed) and a 1TB HDD (on which I installed Pop! OS).

When installing Pop! OS, I created a new boot partition on my HDD (because my old boot partition was on the SSD and not big enough to proceed with the installation) and proceeded with choosing my /, /home, swap and /boot/efi partitions. After a successful installation, when I tried to boot, it just booted into an empty grub command line. I figured it was still trying to boot from the old boot partition on the SSD, so being the fool I am I deleted it.

I then tried to boot into the BIOS, but it just gave me a black screen with an unblinking white cursor on the top left of the screen. I tried scouring forums online and somehow I was able to enter into the BIOS.

Now I'm facing two issues. Firstly, I'm not able to see my bootable devices in the BIOS menu. There is a single entry with the number 2. and no text in it. I can't change it or move it: bios boot priority order

Secondly, my windows installation broke. When I try to boot into windows (using the systemd-boot entry I added using bcdboot) it gives me

The Boot Configuration Data file doesn't contain valid information for an operating system
File: \BCD
Error Code: 0xc0000098

Windows BCD err

Note: I am able to see the windows boot manager and the Pop! OS boot entry when I hold f12 and try to boot, and my Pop! OS installation works smoothly (I can login, run the browser, etc.)

Edit: I tried to reinstall Pop! OS and now I can't load the BIOS. Again.

Edit: I ran sudo systemctl reboot --firmware-setup and now I can load the BIOS again

2 Answers 2

0

I ended up just reinstalling Ubuntu instead of Pop! OS. I recreated my old boot partition and now everything seems to work (my Windows installation and BIOS).

-1

If you still have the external device used to install Pop!_OS, try searching with another deice the key of your computer model for selecting a different boot device for one session (usually F8, F4 or F11) and then a popup will appear for using a boot device for one session instead of changing it on the BIOS, then select your external Pop!_OS installation drive.

Try searching for "BBS Popup key ."

After that, try reinstalling Pop!_OS and it should install the bootloader already with the Windows partition.

1
  • I can already use the f12 boot screen to load Pop! OS or windows boot manager, the problem is that the windows boot manager is above the Pop!OS installation, so it always tries to boot into windows first.
    – ekl1pse
    Commented Oct 17, 2023 at 12:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .