I am having issues where a Debian VM of mine in VMWare Workstation changes it's resolution to 1280x1392 pixel every time I enter fullscreen mode.

Now I could change the resolution manually to 2560x1440px every time I exit and enter fullscreen mode, but would prefer to automate it.

I first tried modifying the .config/xfce4/xfconf/xfce-perchannel-xml/displays.xml file where the configuration is stored manually, but it does not apply the changes. The changes are neither applied if I use the xfconf-query command to set the resolution value.

Something that does work to set the resolution from the command line is xrandr

xrandr --output Virtual1 --mode 2560x1440

Now I thought about setting up a script using inotifywait to monitor changes in display.xml.

But my issue is that it doesn't seem to recognize the changes in the file...

I ran the following command from the command line(Just to test if it even notices the changes):

while inotifywait -m -e modify /home/myhomesir/.config/xfce4/xfconf/xfce-perchannel-xml/displays.xml; do whoami ;done

Then I run md5sum display.xml to get the current md5sum of the settings file, exit and enter Fullscreen and run md5sum display.xml again to confirm that the file has changed:

md5sum displays.xml
001c0796aba8c0e8b4ea28d59f2e5edc  displays.xml

md5sum displays.xml
322e7ea6ca9914caba6fa1365244b27a  displays.xml

Checking the Output of my inotifywait command, I dont get any output:

while inotifywait -m -e delete /home/myhomedir/.config/xfce4/xfconf/xfce-perchannel-xml/; do whoami;done                                        
Setting up watches.
Watches established.

Do you know why this is happening and not recognizing the changes? Two lines are being changed from what I have observed:

diff displays.xml_wrong displays.xml_correct                                                                                                                                                                                                                                                                            
<       <property name="Resolution" type="string" value="1280x1392"/>
<       <property name="RefreshRate" type="double" value="59.998367391363502"/> 
>       <property name="Resolution" type="string" value="2560x1440"/>
>       <property name="RefreshRate" type="double" value="59.950550105254798"/> 

Looking forward to any help. If you have any other suggestions, let me know. Thank you!

1 Answer 1


I think I found the solution, after monitoring for create and move events, it seems that instead of just writing to the file directly, xfce4 first CREATES a new file, displays.xml.new and then MOVES it to display.xml

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .