0

I am trying to install something which needs libjsoncpp1

I've tried without it and it does indeed fail with an error message.

This library does not seem to exist in Debian Bullseye.

It does however exist in some earlier Debian:

https://packages.debian.org/buster/libjsoncpp1

Does anyone know how to install it in Bullseye?

6
  • 1
    Debian Bullseye has the package libjsoncpp24. If that does not satisfy the dependency, then it would probably be easier to use Debian Buster. You could try building the Buster version of libjsoncpp1 for Bullseye if you know how .debs are packaged. Oct 11, 2023 at 20:46
  • Thanks but I already put libjsoncpp24 on there but it was not enough. Do I need to add something to /etc/apt/sources.list ? I did play around with that but did not get anywhere.
    – cardamom
    Oct 11, 2023 at 20:55
  • If you have a package that requires libjsoncpp1 and does not accept libjsoncpp24, then you would have to use libjsoncpp1 which would be solved by using Debian Buster. Adding Buster repositories to your Bullseye install would not be recommended. If you have to use Bullseye, you would want to build the libjsoncpp1 package for Bullseye. Oct 11, 2023 at 21:04
  • Well I think changing the whole OS to an earlier one for this would take hours and unleash other challenges. Any tips how to build this libjsoncpp1 - where would one start?
    – cardamom
    Oct 11, 2023 at 21:09
  • 2
    The Debian Handbook has a section on rebuilding packages. If you have to use Bullseye, have you checked if the software you want to use has a package compatible with Bullseye? Oct 11, 2023 at 21:20

1 Answer 1

0

I solved it with

sudo apt install libjsoncpp-dev

The hint came from here:

https://packages.debian.org/source/bullseye/libjsoncpp

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .