2

I recently encountered a dual-boot issue on my Debian 12 system where Windows 10 was not showing up in the GRUB menu after a Debian update. I spent some time troubleshooting the problem and was able to resolve it. I wanted to share my experience in case others encounter a similar issue.

Issue Description: After a Debian update, my GRUB bootloader stopped showing the option to boot into Windows 10. Initially, I believed my Windows partition was located at /dev/sda2, but it turned out to be at /dev/sda1.

1
  • Your question should only be a question. You should separate the answer you included in your question and put it in an answer to your own question, as encouraged in this help: unix.stackexchange.com/help/self-answer .
    – A.B
    Commented Oct 7, 2023 at 11:55

2 Answers 2

5

For me I also encounter this problem recently when I upgrade my grub2 package from version 2.06-13 to 2.06-13+deb12u1. The solution is to uncomment this line in /etc/default/grub:

GRUB_DISABLE_OS_PROBER=false

Then run sudo update-grub to let GRUB scan for Windows 10. This way I do not need to manually add an entry in /etc/grub.d/.

Note: this update is possibly related to a recent security update: https://www.debian.org/security/2022/dsa-5280

0

Solution:

  1. Verify the Windows Partition: To confirm the location of your Windows partition, you can use commands like lsblk or fdisk -l. In my case, it was /dev/sda1.

  2. Update the Custom GRUB Entry: I added a custom GRUB menu entry for Windows in the /etc/grub.d/40_custom file. Here's what it looked like:

menuentry "Windows 10" {
    insmod ntfs
    set root=(hd0,1)  # Modify this to match your Windows partition
    chainloader +1
}

Make sure to replace (hd0,1) with the appropriate partition information for your Windows installation.

  1. Enable os-prober: In the /etc/default/grub file, ensure that the GRUB_DISABLE_OS_PROBER setting is set to false to enable automatic detection of other bootable partitions.

  2. Update GRUB: Run sudo update-grub to regenerate the GRUB configuration.

After following these steps, my GRUB menu displayed the "Windows 10" option, allowing me to boot into Windows 10 successfully.

Conclusion: If you encounter a similar issue where Windows doesn't show up in the GRUB menu, consider checking the Windows partition location, configuring a custom GRUB entry, and enabling os-prober. This should help you resolve the problem and restore dual-boot functionality.

I hope this post helps others who may face the same issue, and please feel free to ask if you have any questions or need further assistance.

1
  • 1
    Windows in BIOS mode, normally has two NTFS partitions, boot & main install. Most users do not know about boot partition as not normally shown. With UEFI installs both Windows & Linux use same ESP - efi system partition which is FAT32. With UEFI the chain entry to ESP partition is ` chainloader /EFI/microsoft/BOOT/bootmgfw.efi`
    – oldfred
    Commented Oct 7, 2023 at 14:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .