0

After updating to Debian 12, gnome-startup-applications, and more generally, gnome-tweaks stopped working.

$ gnome-tweaks
WARNING: Shell not installed or running

(gnome-tweaks:19742): dconf-WARNING **: 08:17:46.684: failed to commit changes to dconf: The connection is closed
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/gtweak/app.py", line 50, in do_activate
    self.win = Window(self, model)
               ^^^^^^^^^^^^^^^^^^^
  File "/usr/lib/python3/dist-packages/gtweak/tweakview.py", line 58, in __init__
    self._model.load_tweaks(self)
  File "/usr/lib/python3/dist-packages/gtweak/tweakmodel.py", line 107, in load_tweaks
    mods = __import__("gtweak.tweaks", globals(), locals(), tweak_files, 0)
           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/lib/python3/dist-packages/gtweak/tweaks/tweak_group_general.py", line 54, in <module>
    IgnoreLidSwitchTweak(),
    ^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/lib/python3/dist-packages/gtweak/tweaks/tweak_group_general.py", line 28, in __init__
    GetterSetterSwitchTweak.__init__(self, _("Suspend when the laptop lid is closed"), **options)
  File "/usr/lib/python3/dist-packages/gtweak/widgets.py", line 469, in __init__
    sw.set_active(self.get_active())
                  ^^^^^^^^^^^^^^^^^
  File "/usr/lib/python3/dist-packages/gtweak/tweaks/tweak_group_general.py", line 31, in get_active
    return not self._sync_inhibitor()
               ^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/lib/python3/dist-packages/gtweak/tweaks/tweak_group_general.py", line 42, in _sync_inhibitor
    bus = Gio.bus_get_sync(Gio.BusType.SESSION, None)
          ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
gi.repository.GLib.GError: g-io-error-quark: The connection is closed (18)

1 Answer 1

0

I solved this issue as follows. In Debian, there is an option on the initial login screen, in the lower right corner, as shown in the figure below.

enter image description here

Previously, in Debian 11, this option in the lower right corner displayed Wayland and X11. Now, in Debian 12, it shows GNOME, GNOME Classic, and Openbox. I switched to GNOME Classic and Openbox, which didn't work correctly. However, when I returned to GNOME, Tweaks started working again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .