I'm trying to install Fedora (dual-boot) on a brand-new MacBook Pro. The live/installer CD runs flawlessly on the machine, which was a nice surprise. But after the install is completed, I cannot actually boot into Fedora. Here is what I did:

  1. OS X by default ships with an EFI partition (/dev/sda1) and an HFS+ partition (/dev/sda2). I used Boot Camp in OS X to resize the existing OS X partition and reboot to the live CD.

  2. Once the Fedora live CD is booted, I used the disk utility to delete the "Windows" partition (/dev/sda3) that Boot Camp created. This leaves the original EFI and OS X partitions plus a chunk (40G) of empty space at the end of the disk.

  3. Run the Fedora Installer, telling it to automatically partition and install using the free space on the disk. It creates a 500M boot partition (/dev/sda3) and an LVM partition (/dev/sda4).

  4. When the installer gets to the part about the boot loader, I go with the defaults, which is to install GRUB to the boot sector of the Fedora boot partition (/dev/sda3).

After the install is complete, I would expect to be able to hold down the Mac's "Option" key to choose which OS to boot since /dev/sda3 has a boot sector, but only the OS X disk shows up. (What does Boot Camp do, then, besides resizing the disk?)

I read somewhere that a boot loader called rEFIt would help, so I tried that. I installed it using the instructions on the project's website and rebooted. An option to boot Linux shows up in the rEFIt boot screen, but when selecting it, I get a black screen with an error message along the lines of "no operating system found."

Further research suggested that rEFIt had to "resync" in order to find GRUB, even though I installed rEFIt after Fedora. I did that by going into the rEFIt "menu" and answering in the affirmative when it told me that a resync was necessary.

Now, when I select Linux in the rEFIt boot menu, it only shows a gray-out penguin and nothing else happens. The lack of output makes the problem difficult to troubleshoot exactly what's going wrong. Maybe if I knew more about EFI, I could play around in the EFI shell provided by rEFIt.

Anyway, has anyone here had success dual-booting Fedora 14 on a newer Mac, and if so, what procedure did you use? I'd like to install Fedora to the whole disk, but I'm reluctant to try that until I can get a dual-boot scenario to work. I you could, please CC my email address in any responses since I'm subscribed to the digest version of the list.

Thanks for your time.

  • I have Fedora 14 dual booting on an older Mac, using rEFIt. It works fine. Have you tried reinstalling Fedora since you set that up? That'd be my next step.
    – mattdm
    Commented Feb 17, 2011 at 18:45

2 Answers 2


It might sound stupid, but have you made sda3 bootable? You should run the partitioner again and check if the bootable flag is on.

Furthermore, I'd recommend you not use the automatic partitioner when installing Linux alongside OSX. My experience is that they don't like each other (though it's been a year since I've tried).


I have to agree with the above post. In either, Fedora 14 or 15, the auto partitioner is less than ideal and I have had to reinstall OS X cause it it. Just use the last option in the partitioner (cant remember what it is called) and make sure it only uses the free space. The whole side by side partitioner options seems to have problems with HFS+ recognition or something. Manual partitioning is not much harder so go with that

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .