0

I am getting problems setting a 5GHz access point with a lattepanda 3d. I run the following setup:

  • Debian
  • Hostapd
  • Dnsmasq
  • iw (for set/get reg dom)

In the end I am able to successfully test a 2,4 GHz AP setup.

No way to get 5GHz.

While debugging HOSTAPD it seems it is looking for a regulatory domain 00 that got all the 5GHz frequencies no-ir (no-initiating-radiation-> not usable from hostpad).

Usually you change the reg dom to what you need and hostpad will get the working frequencies (I have already been able to do such a thing with a raspi from gui). No way to accomplish:

  • setting kernel option does not work (modprobe cfg80211 ieee80211_regdom=XX or by conf file)

  • iw reg set XX does not work (for phy0 self managed).

  • crda has been deprecated and removed from Debian, I would not install it.

I understand there was a LAR option not anymore accessible (would need an older kernel/driver?), that would have made the trick if set to =disabled. It has been removed from configurable paramenters for the iwlwifi driver.

I cannot understand how to solve the problem and why it should be such complicated.

I do not know if that is clear, please help me...

regards

ed

1 Answer 1

0

From the iwlwifi driver, I assume you are using an Intel WiFi adapter.

Unfortunately, all the newer Intel WiFi adapters seem to have a built-in restriction that disallows the use of the 5 GHz frequencies in AP mode. It might be built into the adapter firmware, so the driver may not be able to override it at all.

1
  • ok. thank you. I was expecting such kind of answer. just to confirm, I got the same from lattepanda support.
    – enon
    Commented Sep 28, 2023 at 7:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .