4

I am currently setting up a personal server on Debian Wheezy. My machine is an ARM based architecture (Cubox).

The problem appear when I want to mount and use my NTFS external hard drives. The mount point is correct, I can access files and folders, I can change owner but it is impossible to write files even as root.

I mount my drives with "mount -o options source destination" The command mount gives rw option for this mounted drive.

1
  • 1
    Have you installed the ntfs-3g package?
    – Spack
    Commented May 13, 2013 at 17:22

2 Answers 2

4

You need "fuse" and "ntfs-3g" for this to work. From what I read cubox has this in the kernel so you can try:

mount -t ntfs-3g /dev/sdb1 /mnt/ntfs/

Change the paths to suit.

2
  • Normally it is sufficient to install the packages: apt-get update ; apt-get install ntfs-3g. You do not need to specify the file system explicitly in mount because in Debian 6.0 (squeeze) and newer /sbin/mount.ntfs is symlinked to /sbin/mount.ntfs-3g. Commented Mar 5, 2015 at 4:25
  • ERROR ".... failed to access mountpoint /mnt/ntfs: No such file or directory" Commented Feb 18, 2018 at 12:17
0

In my case the NTFS Partition was open by windows (as in windows 8 and newer Fast startup is enable by default )

1- Disable fast startup using the following method:

2-

1 Type Control Panel in the search box.
2 Click Control Panel.
3 Click Power Options.
4 Click Choose what the power buttons do.
5 Click Change settings that are currently unavailable.
6 Scroll down to Shutdown settings and unchecked Turn on fast startup.
7 Click Save changes.

3-power off the windows and you can now write to NTFS partition (Tested using Debian 9.3 & windows 10 dual boot grub )

You must log in to answer this question.