0

This is the situation. I have setup a hostapd server on Slackware 15 I use this adapter for server, the client also using a similar adapter.

I use this configuration for hostapd

interface=wlan1
bridge=br0
driver=nl80211
ssid=mysid
hw_mode=a
channel=36
ieee80211d=1
ieee80211n=1
ieee80211ac=1
wmm_enabled=1
macaddr_acl=1
accept_mac_file=/etc/hostapd/hostapd.accept
auth_algs=1
ignore_broadcast_ssid=0
wpa=2
wpa_passphrase=mysid
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP
country_code=IT

#HT
require_ht=1
require_vht=1
ht_capab=[MAX-AMSDU-7935][HT40+][SHORT-GI-20][SHORT-GI-40]

I start hostapd and speed seems good

on server iwconfig report:

wlan1     IEEE 802.11AC  ESSID:"mysid"  Nickname:"WIFI@RTL88X2BU"
          Mode:Master  Frequency:5.18 GHz  Access Point: *******   
          Bit Rate:867 Mb/s   Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=1/100  Signal level=1/100  Noise level=0/100
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

on client iwconfig report

wlan1     IEEE 802.11AC  ESSID:"mysid"  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency:5.18 GHz  Access Point: *******
          Bit Rate:434 Mb/s   Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=100/100  Signal level=53/100  Noise level=0/100
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

The problem is..after two-five minutes of use the client is disconnect from AP and it can not reconnect, I have to restart hostapd (sic!).

The kernel is 6.5.3 and this is the driver.

I have tried those solutions

a) removing ht_capab=[MAX-AMSDU-7935][HT40+][SHORT-GI-20][SHORT-GI-40] the hostapd become slow to 173mb and the problem persist.

b) configuring the bridge using network manager or ip commands , but is the same thing, actually I use brctl for configure it.

This is the verbose log from hostapd.

+

Some new errors today

1695839108.387288: nl80211: set_key failed; err=-100 Network is down
RSN: PTK removal from the driver failed
wlan1: AP-STA-POSSIBLE-PSK-MISMATCH 
5
  • 1
    random suggestions: by trial and errors, could anything work better with: not using a bridge at all? sure there's no network filter anywhere preventing the EAPOL frames to be received? if the ssid is invisible, using a non-invisible ssid? etc.
    – A.B
    Sep 27, 2023 at 11:21
  • Thanks. There is a firewall, which port I have to open for EAPOL?
    – elbarna
    Sep 27, 2023 at 11:48
  • 1
    eapol would be an Ethernet frame type, so only a low level firewall or a bridge firewall would disrupt it. It's also most likely hostapd retrieves it directly on wlan1 without it having to appear anywhere else Anyway not using a bridge is a simpler setup worth an attempt. likewise not trying to hide the ssid if it's hidden etc.
    – A.B
    Sep 27, 2023 at 11:58
  • Thanks, was probably the ebtables firewall, now I check
    – elbarna
    Sep 27, 2023 at 17:56
  • I have tried with firewall down and..same thing.
    – elbarna
    Sep 27, 2023 at 18:27

1 Answer 1

0

Solution found thanks to morrownr.

Finally seems to be working, I ping a machine since 9 minutes without any disconnection.


ps -eO etime |grep ping|grep -v grep
 5149       08:59 S pts/2    00:00:00 ping 10.3.1.1

Actually I'm testing it on "HP gen8 microserver" with Debian 12 , I hope don't make problems on Raspberry (I will test soon), those configurations files

/etc/modprobe.d/88x2bu.conf

 options 88x2bu rtw_drv_log_level=0 rtw_led_ctrl=0 rtw_vht_enable=2 rtw_power_mgnt=1 rtw_beamform_cap=0 rtw_dfs_region_domain=1 rtw_switch_usb_mode=1

hostapd.conf

interface=wlx60fb0063376d
bridge=br0
driver=nl80211
ssid=RouterVdr
hw_mode=a
channel=44
ieee80211d=1
ieee80211n=1
ieee80211ac=1
wmm_enabled=1
auth_algs=1
ignore_broadcast_ssid=0
country_code=IT

# WPA
wpa=2
wpa_passphrase=mypass
wpa_key_mgmt=WPA-PSK SAE
wpa_pairwise=CCMP
rsn_pairwise=CCMP
sae_password=mypass
wps_cred_add_sae=1
ieee80211w=2
own_ip_addr=127.0.0.1

#HT
require_ht=1
require_vht=1
ht_capab=[MAX-AMSDU-7935][HT40+][SHORT-GI-20][SHORT-GI-40]

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .