According to manual I thought that systemd-remount-fs.service is responsible for parsing and applying /etc/fstab entries. So I tried to test it: I removed ExecStart part (ExecStart=/lib/systemd/systemd-remount-fs) and rebooted the system. After booting and logging in I still had fstab entries in mount.

And now I am wondering if it's the kernel's job itself? How can I do a job before fstab entries get mounted (in case it's kernel's job)?

  • 1
    Thanks for MC68020 for pointing me in the right direction, regarding the second part of my question, this comment on github is a good start for anyone interested.
    – SAMPro
    Sep 25 at 7:19

1 Answer 1


The kernel usually mounts the root filesystem at the very end of the boot sequence.
It is usually mounted readonly and irrespective of whatever mount option set as part of the /etc/fstab file.

Control is then, given to the init system.

As specified in the manual you linked to, systemd-remount-fs.service :

ignores normal file systems and only changes the root file system (i.e. /), /usr/, and the virtual kernel API file systems such as /proc/, /sys/ or /dev/.

You can also read that this service :

is usually pulled in by systemd-fstab-generator

systemd-fstab-generator is in fact responsible for instantiating the initial mount of filesystems according to fstab entries.

This will instantiate mount and swap units as necessary.

It is therefore normal that if you inhibit the automatic execution of systemd-remount-fs.service and reboot, you'll still see your filesystems mounted according to the /etc/fstab entries.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .