5

I've been trying to downgrade to Gimp 2.8.22 on Linux Mint 20, which is based on Ubuntu 20. I have been unable to find pre-made binaries for Linux (though plenty exist for Windows and Mac). The narrative goes "Simply compile the source!" but I am unable to do this because a few dependencies (such as gegl 0.2) are apparently not available for modern Ubuntu-based systems.

Does anyone know of a way to get Gimp 2.8.22 on newer Linux systems? Hopefully something statically linked? Or at least have a guide on building this given modern constraints? I have tortured myself with Gimp 2.10 for the last two years thinking one day I'll enjoy it. But the more I use this software the more I fear I'll finally break and inject myself with hydrogen cyanide while laughing hysterically.

3
  • 2
    Just a few quick notes... Older versions of the Gimp have bugs which cause them to crash with newer versions of glib, so installing the old 18.04 packages doesn’t work, and rebuilding the old source code on a current system would also result in a non-functional program. As you suggest, you need a static build with a working set of libraries; alternatively, a sandboxed runtime again with a working set of libraries. (This is nowhere near an answer, I just want to avoid unproductive suggestions such as “install the 18.04 packages”.) Commented Sep 22, 2023 at 6:09
  • @sudodus Rebooting an entire OS just to use one application seems like a really slow workflow though, unless I'm missing something obvious. I've used installs on a per-feature basis before, it prevents getting into any form of efficient flow. Even a chroot might be a better option, which is painful for a multitude of reasons. Commented Sep 22, 2023 at 8:07
  • @StephenKitt Thank you for the insight. I've tried newer libs with older packages in the past and indeed had the kinds of issues you mention. Commented Sep 22, 2023 at 8:09

3 Answers 3

5

The easiest way to install an older or newer version of a program with complex dependencies is to install a Debian/Ubuntu release that comes with the version you want. There's an easy way to install Debian/Ubuntu releases that live “under the hood” and run only specific programs from them: schroot to set up an environment for the other OS release and debootstrap to perform the installation. The schroot environment runs programs with the other OS's libraries and everything else from your normal Linux OS: kernel, network, home directory, etc.

For Gimp 2.8.22, get Ubuntu 18.04.

apt-get install schroot debootstrap
mkdir -p /chroot/bionic
debootstrap bionic /chroot/bionic

Create a file /etc/schroot/chroot.d/bionic containing:

[bionic]
description=Ubuntu 18.04
directory=/chroot/bionic
type=directory

Create a file /usr/local/bin/gimp containing:

#!/bin/sh
exec schroot -p -c bionic -- gimp "$@"

Finish the setup:

schroot -c bionic -- apt-get install software-properties-common
schroot -c bionic -- add-apt-repository universe
schroot -c bionic -- apt-get update
schroot -c bionic -- apt-get install gimp
chmod +x /usr/local/bin/gimp

Beware that since Ubuntu 18.04 isn't updated anymore, you won't get any security update. So take care not to open any suspicious files!

9
  • So your advice got me pretty close. Gimp didn't have any install candidates, so I first ran apt install software-properties-common; add-apt-repository universe; apt-update inside the schroot which allowed me to install Gimp. I should note I had to add my regular user to the users group to run without root from the host, this wasn't default. Version 2.8 is now installed, but I cannot run it; I get the error: Cannot open display: even if I export my display var via export DISPLAY=:0. Any ideas on what the issue might be? Commented Sep 25, 2023 at 12:40
  • @aggregate1166877 GUI applications need access to a file containing “cookies”. The default location is ~/.Xauthority but the environment variable XAUTHORITY can point to a different file. Maybe this file isn't visible in the chroot. What is the output of export | grep -e DISPLAY -e XAUTHORITY outside and inside the schroot? Commented Sep 25, 2023 at 13:24
  • @aggregate1166877 Also, inside and outside the chroot: df /tmp /run/user Commented Sep 25, 2023 at 13:35
  • I can't paste multi-line outputs in the comments, so things may look a bit cramped. export | grep -e DISPLAY -e XAUTHORITY -> declare -x DISPLAY=":0" declare -x XAUTHORITY="/home/user/.Xauthority". Host df: Filesystem 1K-blocks Used Available Use% Mounted on \n tmpfs 24724624 3224 24721400 1% /tmp \n tmpfs 4944928 1768 4943160 1% /run schroot df: df: /run/user: No such file or directory \n Filesystem 1K-blocks Used Available Use% Mounted on \n tmpfs 24724624 3856 24720768 1% /tmp Commented Sep 26, 2023 at 0:37
  • 1
    @aggregate1166877 Oh, I forgot you need to pass -p to schroot to preserve environment variables. Sorry about that. Commented Sep 27, 2023 at 9:16
2

As of writing, it's possible : A flatpak is provided through gimp.org for old-stable version (2.8.22 for now). As flatpak should be buit-in since mint 18.3, try just clicking the provided link, or follow the manual procedure described :

  • check if flatpak is installed on your system with sudo apt list flatpak, otherwise install it with sudo apt update && sudo apt install flatpak.
  • install gimp 2.8.22 with (sudo?) flatpak install https://flathub.org/repo/appstream/org.gimp.GIMP.flatpakref

PS : Sorry for sudos, I don't know if it's needed with flatpak. I'm not a mint/ubuntu user.

2
  • Thank you, I will try this and let you know if it works. Only sad part is that this requires 5GB for the install, but I'm willing to bite that bullet. Commented Sep 22, 2023 at 8:11
  • Unfortunately this installs the latest version of Gimp, which is 2.10. I cannot get it to install 2.8. Apparently one can force older versions using flatpak remote-info which allows combing through update hashes to try find the correct patch version, but apparently even then there's a limit to how far back you can go. It also doesn't help that flatpak hashes don't match git commit hashes. Whilst I really like your answer, I think it might not solve the problem in this particular case. Commented Sep 25, 2023 at 12:02
0

Some mirror keep lots of archives https://ftp.belnet.be/ubuntu.com/pool/universe/g/gimp/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .