0

I am trying to print to Epson WorkForce WF-2650 All-In-One Inkjet PRinter from my Arch Linux desktop. Both the desktop and the printer are in network range 192.168.0.1/24.

  1. Initialize Printer Service

The first thing I did was to install CUPS.

sudo pacman -Syu cups cups-pdf

Then I enabled then started the service.

sudo systemctl enable cups
sudo systemctl start cups
  1. Add Printer

After setting up the printing service I tried to add the printer via Gnome Print. I was able to locate the printer by ip but as soon as clicked add I got Failed to add new printer.

Since that failed I moved to the CUPS web page on localhost:631. On navigating Administration > Printers > Add Printer I saw my printer in Discovered Network Printers. When I hit Continue it identified the connection as lpd://192.168.0.156:515/PASSTHRU. However there were only two models to choose from: 9-Pin Series and 24-Pin Series which do not correspond to my printer.

So I fell back to the Generic drivers. I tried printing a small PDF file with the Generic IPP Everywhere Printer and Generic PDF Printer drivers but neither of them printed properly. In both cases I got plaintext gibberish.

Command lpadmin -p WF2650 -E -v lpd://192.168.0.156:515 -m everywhere did not work either, so I started searching for functional drivers.

  1. Find Printer Drivers

When I searched the official repository, I only found one package for scanner drivers and no printer drivers. Nonetheless I did try sudo pacman -Syu imagescan and it did succeed but no printer drivers.

Then I visited AUR and found a lot of Epson-related packages. There were two AURs and I wasn't sure which one covered my printer so I tried both.

https://aur.archlinux.org/packages/epson-inkjet-printer-escpr https://aur.archlinux.org/packages/epson-inkjet-printer-escpr2

For both AURs I downloaded the snapshot containing the PKGBUILD, extracted then cd'd to it. Then I downloaded the source in that directory and tried to install each. Unfortunately both attempts failed.

sudo pacman -U ./epson-inkjet-printer-escpr2-1.2.3-1.tar.gz 
loading packages...
error: missing package metadata in ./epson-inkjet-printer-escpr2-1.2.3-1.tar.gz
error: './epson-inkjet-printer-escpr2-1.2.3-1.tar.gz': invalid or corrupted package
sudo pacman -U ./epson-inkjet-printer-escpr-1.8.0-1.src.rpm 
loading packages...
error: missing package metadata in ./epson-inkjet-printer-escpr-1.8.0-1.src.rpm
error: './epson-inkjet-printer-escpr-1.8.0-1.src.rpm': invalid or corrupted package

Then I went to the official Epson download page and searched. Unfortunately only deb and rpm packages are provided. I considered converting one of the two into a compatible format but the site suggested against it.

If you want to use the driver other than the above distribution, we recommend that you build from the source file and install it.

Is it okay install the deb package with dpkg on Arch? Would it break my system? If it is not an option what should I do from here?

2

1 Answer 1

0

The brute force way is to extract the files from the .deb (or whatever else) and place them in the system paths on your computer. This is not a very clean way, and will cause some issues if you want to uninstall later because the pacman won't be aware of the files.

What you would need to do is instead write a PKGBUILD that does the same thing, so that the files can be installed as a package. But you don't need to do that because there is already an AUR package someone made.

Your problem is not about installing unofficial drivers, but about troubleshooting a general AUR install error. You should either edit this question, or ask a new one.

This site is temporarily in read-only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .