1

as far as i can tell, everything is configured correctly. the service file is as follows:

[Unit]
Description=Start x11vnc at startup
After=multi-user.target

[Service]
Type=simple
ExecStart=/usr/bin/x11vnc -auth guess -display :0 -forever -loop -noxdamage -repeat -rfbauth /etc/x11nvc.pass -rfbport 5900 -shared
ExecStop=/usr/bin/killall x11vnc
Restart=on-failure
RestartSec=5

[Install]
WantedBy=multi-user.target

the password is stored in /etc/x11vnc.pass using sudo x11vnc -storepasswd /etc/x11vnc.pass. i have reloaded the daemon: sudo systemctl daemon-reload and enabled the service: sudo systemctl enable x11vnc, and started the service sudo systemctl start x11vnc.

on reboot, the service comes up just fine, but when i attempt to access it with VNC Viewer, after entering the correct password, i simply get a password check failed error:

enter image description here

here's the kink: when i go to the machine itself and open the x11vnc utility, once i check the Allow Connections button, everything works just fine. problem is, this is an unattended kiosk panel and we can't be doing that everytime it restarts... because it's on the other side of the country.

system is Debian 10.13 Buster and there is no firewall running yet.

can someone kindly point out what i am missing?

1 Answer 1

1

after a LOT of testing, i found two major things that solved this problem:

  1. remove ALL traces of prior VNC configurations from either x11vnc OR ANY OTHERS. make especially sure to remove any VNC-related files from the ~/.config/... paths.

  2. rerun x11vnc -storepasswd and use the path suggested. for some reason, even though it is specified in the service file, x11vnc worked more consistently when the passwd file was in the suggested path.

i know some are going to say that this could be fixed with a clean install, but, since existing setups and configs were in place on running systems, a wipe wasn't feasible. since we'd deployed to 10 machines, it was simple fare after that to have a cleanup script go and fix the issues. i hope this is useful to someone else so they don't have to waste a couple days fretting like i did.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .