0

Some time ago, my Linux computer stopped recognizing the keyboard.
No matter what type of keyboard (PCI, USB), it just doesn't work.

But in those same ports other peripherals do work (Mouse, Pendrive, etc.) but not the keyboard.

I've looked for solutions but they all involve fiddling with the bios or typing certain commands and so on, which I can't do without a keyboard.
The keyboard lights turn on when you turn on the computer, but in the bios splash nothing works anymore.

I already reset the bios, replaced the peripherals, did maintenance on the internal parts. But nothing makes my computer accept any type of keyboard (And it's just the keyboard).
I wanted to install a new operating system, but all the ISOs ask you to press a key first to start the installation (the keyboard does not work) so I couldn't. and the bios settings don't work either because it doesn't recognize the keyboard.

Hardware: Keyboards USB/PCI Generic

Motherboard:

Software:

  • Operating System: Debian GNU/Linux 11
  • KDE Plasma Version: 5.20.5 KDE Frameworks Version: 5.78.0 Qt Version: 5.15.2
  • Kernel Version:5.10.0-22-amd64 OS Type: 64-bit

I don't know what to do anymore, I appreciate any ideas.

3
  • 2
    is it the ¬ key not working or all of it? Sep 17, 2023 at 19:01
  • Have you tried this keyboard on a different computer to verify that it works? If that works, and if other keyboards also do not work on a USB live boot while a mouse does... that should not be possible because it does device negotiation at the OS level and on a live boot, the OS is clean, and with a mouse working, clearly the hardware is fine
    – Luc
    Sep 18, 2023 at 0:16
  • 1
    what is a PCI keyboard? If you disconnect everything USB and only have one of your many keyboards connected, does it work? I only suggest this because I have a mouse that does strange things to some computers! i.e. it prevents me from getting into BIOS, regardless of the method (DEL/F2 on POST, various ways of booting into BIOS from various operating systems, etc) This isn't the same as your problem, but you never know, some other USB device may be the issue Sep 18, 2023 at 7:38

1 Answer 1

0

really a complex problem, since at first you can't use the keyoard. Well, you can try these other possibilities:

-HardProblem at your Southbridge/ICH, like a phisycal damage. Maybe you you have to change your motherboard, or check with technical assistance wether this is hardware damage.

-Do you you have another port at your pc? You can use a adaptar USB/PS2 to this other port and check wether it works.

3
  • I have tried with the USB ports. The keyboard doesn't work either. It worked before but after the failure it doesn't work. If I connect a mouse, pendrive, or even a webcam, they work. but not the keyboard.
    – Katamuto
    Sep 17, 2023 at 20:02
  • you can try plug a numeric pad (if you have one), which is not a complete keyboard, and check wether this works.
    – cavernoso
    Sep 17, 2023 at 20:07
  • I don't have a numeric keyboard, but I tried an ultra-compact tablet keyboard (USB) and it doesn't work either. Unfortunately my PC doesn't have Bluetooth or Wi-Fi so I can't use wireless keyboards either. It's quite inconvenient. I can understand that it is some hardware failure. but the usb should work and it doesn't. I also tried all my keyboards on another PC and they work fine.
    – Katamuto
    Sep 18, 2023 at 1:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .