I am using Arch and bash. All packages are current and up to date.

I am using the nnn file manager.

I go into nnn and make a selection of 3 files by pressing the space bar while over each of the three files. This is how files are selected in nnn.

Then I should be able to press the r key to batch edit the selected filenames in neo-vim.

When I press r I see failed! in the bottom left hand corner of the terminal.

This is a rapid and very useful way to re-name files in a dir.

It was working and for some unknown reason has stopped.

ps nnn has no .config file to speak of and is set-up in .bashrc. Within .bashrc I have the following:

# setup bookmarks in nnn
export NNN_BMS='s:/home/$USER/linux_config'

# set nnn editor

export NNN_OPTS="H"
  • when I comment out the bookmarks line in .bashrc the problem persists
    – Kes
    Sep 17 at 9:19
  • same failure! response to the r key when using termite, lxterminal or xfceterminal to launch nnn from, in any directory I have tried
    – Kes
    Sep 17 at 10:07

1 Answer 1


This is a working solution

nnn has many plugins as we see here https://github.com/jarun/nnn/tree/master/plugins

After reading this https://github.com/jarun/nnn/wiki/Troubleshooting#default-batch-rename-limits on the nnn page, I decided to download all the plugins, I will explore some of these anyway, so I could have use of the .nmv plugin, thinking it's presence might solve the problem.

So I opened up /home/$USER/.config/nnn/plugins and git cloned the plugins from here https://github.com/jarun/nnn.git into the plugins directory, and now everything is working.

The r key is now working as it should and I can batch edit file names again.

I'm sure this worked before without the plugins installed, so I still don't know why it did not work without them.

But it's a working solution if anyone else comes across this problem.

Still, I'd be interested to know what the problem is if anyone has any ideas.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .