1

I want to be able to connect remotely to my daily driver (Debian 11) within my LAN from my laptop and other devices. Ssh works fine but niether Chrome nor Firefox are happy running over ssh / some tasks are easier done from a GUI environment. The laptop runs MS-Windows 10 and I usually use Mobaxterm to connect.

Specifically, I want the computer to continue functioning as a workstation running X with graphical login while also providing multi-user GUI sessions over the network. My choices therefore appeared to be: XDMCP, VNC or RDP. I have in the past provisioned all 3 successfully - but none recently. I expected this to be straightforward.

As a precursor to running the following, I installed lightdm in pace of sddm and ensured that there were no iptables rules in place. Login via the console is still functioning, but I have failed to get XDMCP or VNC working. I've not tried with RDP as my previous experience was that this was not as robust as the other mechanisms.

  1. Trying XDMCP: Amended /etc/lightdm.conf , added: [XDMCPServer] enabled=true

Rebooted. netstat -nap showed lightdm listening on UDP 0.0.0.0:177. When I attempted to connect from a MS-Windows machine running Mobaxterm, a window opened and closed immediately. lightdm.log shows:

[+344.80s] DEBUG: Got Query(authentication_names=[]) from 192.168.0.87:57445
[+344.80s] DEBUG: Send Willing(authentication_name='' hostname='animal' status='') to 192.168.0.87:57445
[+345.04s] DEBUG: Got Request(display_number=1 connections=[] authentication_name='' authentication_data= authorization_names=['MIT-MAGIC-COOKIE-1' 'XDM-AUTHORIZATION-1'] manufacturer_display_id='') from 192.168.0.87:57445
[+345.04s] DEBUG: Send Decline(status='No valid address found' authentication_name='' authentication_data=) to 192.168.0.87:57445

Google found 6 hits when I searched for the error message in the last log entry there - they didn't help me.

  1. Trying VNC. I backed out the changes above, added:
    [VNCServer]
    enabled=true
    command=Xvnc
    port=5900
    listen-address=0.0.0.0
    width=1024
    height=768
    depth=8

Rebooted. Again netstat -nap showed lightdm listening on TCP 0.0.0.0:5900. On trying to connect using Mobaterm, the client prompted me for a password which I left blank and got "Connection closed". This repeated a second time. Log entries shown below.

[+50.20s] DEBUG: Got VNC connection from 192.168.0.87:52259
[+50.20s] DEBUG: Seat vnc0: Loading properties from config section Seat:*
[+50.20s] DEBUG: Seat vnc0: Starting
[+50.20s] DEBUG: Seat vnc0: Creating greeter session
[+50.20s] DEBUG: Seat vnc0: Creating display server of type x
[+50.20s] DEBUG: XServer 1: Logging to /var/log/lightdm/x-1.log
[+50.20s] DEBUG: XServer 1: Writing X server authority to /var/run/lightdm/root/:1
[+50.20s] DEBUG: XServer 1: Launching X Server
[+50.20s] DEBUG: Launching process 1430: /usr/bin/Xvnc -rfbauth /etc/vncpasswd :1 -auth /var/run/lightdm/root/:1 -nolisten tcp -inetd -geometry 1024x768 -depth 8
[+50.20s] DEBUG: XServer 1: Waiting for ready signal from X server :1
[+50.20s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat1
[+50.23s] DEBUG: Process 1430 exited with return value 1
[+50.23s] DEBUG: XServer 1: X server stopped
[+50.23s] DEBUG: XServer 1: Removing X server authority /var/run/lightdm/root/:1
[+50.23s] DEBUG: Seat vnc0: Display server stopped
[+50.23s] DEBUG: Seat vnc0: Stopping session
[+50.23s] DEBUG: Seat vnc0: Session stopped
[+50.23s] DEBUG: Seat vnc0: Stopping display server, no sessions require it
[+50.23s] DEBUG: Seat vnc0: Stopping; greeter display server failed to start
[+50.23s] DEBUG: Seat vnc0: Stopping
[+50.23s] DEBUG: Seat vnc0: Stopped
[+57.93s] DEBUG: Got VNC connection from 192.168.0.87:52260
[+57.93s] DEBUG: Seat vnc1: Loading properties from config section Seat:*
[+57.93s] DEBUG: Seat vnc1: Starting
[+57.93s] DEBUG: Seat vnc1: Creating greeter session
[+57.93s] DEBUG: Seat vnc1: Creating display server of type x
[+57.93s] DEBUG: XServer 1: Logging to /var/log/lightdm/x-1.log
[+57.93s] DEBUG: XServer 1: Writing X server authority to /var/run/lightdm/root/:1
[+57.93s] DEBUG: XServer 1: Launching X Server
[+57.93s] DEBUG: Launching process 1431: /usr/bin/Xvnc -rfbauth /etc/vncpasswd :1 -auth /var/run/lightdm/root/:1 -nolisten tcp -inetd -geometry 1024x768 -depth 8
[+57.93s] DEBUG: XServer 1: Waiting for ready signal from X server :1
[+57.93s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat2
[+57.94s] DEBUG: Process 1431 exited with return value 1
[+57.94s] DEBUG: XServer 1: X server stopped
[+57.94s] DEBUG: XServer 1: Removing X server authority /var/run/lightdm/root/:1
[+57.94s] DEBUG: Seat vnc1: Display server stopped
[+57.94s] DEBUG: Seat vnc1: Stopping session
[+57.94s] DEBUG: Seat vnc1: Session stopped
[+57.94s] DEBUG: Seat vnc1: Stopping display server, no sessions require it
[+57.94s] DEBUG: Seat vnc1: Stopping; greeter display server failed to start
[+57.94s] DEBUG: Seat vnc1: Stopping
[+57.94s] DEBUG: Seat vnc1: Stopped

I also tried with 'command=Xvnc -SecurityTypes None' and with 'command=Xvnc -rfbauth /etc/vncpasswd' after setting a VNC password. Logs were similar to above.

I also tried the first configuration using an Android tablet withe RealVNC viewer. This did not prompt for a password, but reported "connection closed" immediately.

2
  • 1
    For VNC, the problem appears to be depth=8 - amending to depth=24 the connection works as expected.
    – symcbean
    Sep 11, 2023 at 15:02
  • ....or almost as expected - I also amended the resolution to 1650x1050 in lightdm.conf but after login session ran at 1024x768 in a box at the top left of the viewer window - xrandr provided temporary relief
    – symcbean
    Sep 11, 2023 at 15:55

0

You must log in to answer this question.

Browse other questions tagged .