2

I wanted to install texmaker the other day but I ran into an issue : it downloaded 500mb but it told me it could not find a few dependencies, for instance

Err : 4 http://deb.debian.org/debian/pool/main/t/texlive-bin/texlive-binaries_2022.20220321.62855-5.1_amd64.deb 404 Not Found [IP : .... 80]

I looked it up on the repo, it was there with a different name : http://deb.debian.org/debian/pool/main/t/texlive-bin/texlive-binaries_2022.20220321.62855-5.1+deb12u1_amd64.deb

The error suggested that i run the command with --fix-missing and run apt update before, but it didnt work. So i tried to download the file and install it with sudo apt install ./texlive-binaries...+deb12u1_amd64.deb. Then running sudo apt install texmaker still did not found the package as it recognized the version is 5.1+deb12u1_amd64 and not 5.1. I looked it up on google, did not find much, and moved on Overleaf.

But today, i ran apt update && apt upgrade, and after i reboot i come to a tty. I am surprised. I found out i can't start gnome with startx or sudo systemctl enable gdm3. It turns out apt updated gnome-shell-common to a deb12u1_amd64 version, and it broke the DE.

Now apt lists all the gnome packets as installed automatically and not needed anymore, aswell as bolt, gir1, ibus, ...

I am confused, when i run apt install gdm3 it tells me gnome-shell depends on gnome-shell-common = 43.4-1 but 43.6-1~deb12u1 will be installed. Impossible to fix the problem.

I looked up /etc/apt/sources.list but everything seems fine :

deb http://deb.debian.org/debian bookworm flags
deb-src http://deb.debian.org/debian bookworm flags

deb http://security.debian.org/debian-security bookworm-security flags
deb-src http://security.debian.org/debian-security bookworm-security flags

deb http://deb.debian.org/debian bookworm-updates flags
deb-src http://deb.debian.org/debian bookworm-updates flags

where flags is main non-free-firmware non-free contrib. Also in source.list.d I have vscodium.list which contains deb [singed-by = /usr/share...gpg ] https://download.vscodium.con/debs vscodium main

apt policy gnome gnome-shell returns

gnome:
  installed : none
  candidate : 1:43+1
  version table :
    1:43+1 500
    500 http://deb.debian.org/debian bookworm/main amd64 Packages
gnome-shell:
  installed : none
  candidate :43.4-1
  version table :
    43.4-1 500
    500 http://deb.debian.org/debian bookworm/main amd64 Packages
    100 /var/lib/dpkg/status

Here is the content of apt update :

Reached :1 http://deb.debian.org/debian bookworm InRelease
Reached :2 http://security.debian.org/debian-security bookworm-security InRelease
Reached :3 http://deb.debian.org/debian bookworm-updates InRelease
Reached :4 http://download.vscodium.com/debs vscodium InRelease
Reading list ... done
Constructing dependency tree ... done
Reading information status ... done
1 packet can be updated. Run apt list --upgradable to see it

Now I have a new update which is nvidia-installer-cleanup and apt policy nvidia-installer=cleanup is :

nvidia-installer-cleanup:
  installed : 20220217+2
  candidate : 20220217+3~deb12u1
  version table :
    20220217+3~deb12u1 500
      500 http://deb.debian.org/debian bookworm/contrib amd64 Packages
    20220217+2 100 
      100 /var/lib/dpkg/status

But i think i found the issue. I have a Brother HL-2135W printer that used to work on Debian 11. However, this time it did not work out of the box so when i tried to install it with the script found on Brother's support website, it was a 32 bit script : https://www.brother.fr/services-et-supports/hl-2135w/downloads

The script messed up libc6-i386. I had to run dpkg -add-architecture i386 which messed up apt. dpkg -l | grep i386 outputs

cupswrapperhl2130:i386
hl2130lpr:i386

so I uninstalled those two packages and run dpkg --remove-architecture i386. But I still can't install gnome. There is a deeper issue with apt probably.

I run Debian 12 bookworm on an Dell Inspiron 5415 with Ryzen 5 5500U.

Thanks for your help.

2
  • deb12u1 means that it’s the first post-release update for Debian 12. It’s usually a good idea to install those versions ;-). Does it help if you run rm /var/lib/apt/lists/*.debian.org.* and then apt update? (And check apt policy gnome-shell after that — it should show 43.6-1~deb12u1.) Sep 11, 2023 at 13:03
  • Flushing /var/lib/apt/lists/*.debian.org_* did the work, then i ran apt update and i was able to reinstall gdm3, thank you very much for your help :) how do i mark the post as resolved ? Sep 12, 2023 at 15:50

1 Answer 1

2

Somehow the local cache of repository information on your system is outdated, and apt update isn’t updating it. To fix that, delete the local cache:

rm /var/lib/apt/lists/*.debian.org_*

and then run

apt update

again (both as root).

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .