0

I've been struggling for a few days now looking for a driver that would bring my Wi-Fi adapter back to life, but I haven't succeeded so far. My adapter is Realtek Semiconductor Corp. 802.11ac NIC (0BDA:C811) and I can't make it work properly. The most annoying thing is that it seems to have no problem running monitor mode, e.g. with aircrack-ng related tools, it shows both 2.4GHz and 5GHz access points, but when it comes to managed mode, it can't connect to the AP no matter the frequency. The issue must be related to the driver itself, because the same device works perfectly on my other Windows 11 machine, and the AP itself works just fine with other devices connected. So far I've installed numerous 8821CU drivers from github (as I'm unable to find the 8811CU one), but none works. The last occurence of a 8811CU driver (which worked just fine back in the day) I can recall is this one: https://github.com/brektrou/rtl8821CU but it's obsolete right now and can't compile.

Does anyone have any suggestions?

Edit: I've also tested this issue on 3 different distros: Ubuntu 22.04 6.2 kernel, Kali Linux 6.4 kernel and Parrot OS 6.1 kernel. Each one has this problem, so I conclude that no distro is single-handedly responsible for the issue.

Edit 2: I managed to make it work, but not all the time - the adapter, given enough time (several minutes after session start) is now able to connect to any network available, but the connection is not reliable as there are moments of major packet loss %, or it disconnects from the AP once in a while, again tries to reconnect for several minutes, etc. Bitrate is unaffected, though.

1 Answer 1

0

The driver is added to kernel 6.2 and newer.

In Ubuntu

sudo add-apt-repository universe
sudo apt update
sudo apt install rtl8821ce-dkms
sudo modprobe 8821cu
1
  • When installing this package (precisely during module building), I get Error! The /var/lib/dkms/rtl8821ce/5.5.2.1/6.2.0-32-generic/x86_64/dkms.conf for module rtl8821ce includes a BUILD_EXCLUSIVE directive which does not match this kernel/arch. This indicates that it should not be built. Skipped.. Besides, as I stated, I've tried numerous 8821CU drivers from github, from which none works properly. Aren't chipsets 8821CU and 8811CU different?
    – pazdinho_
    Sep 9, 2023 at 19:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .