13

How can I set up Chromium to open Transmission when clicking on a magnet link such as on TPB?

Chromium says that it will use xdg-open but that generally doesn't do anything

System: Manjaro Linux 0.8.5.2 fully upated

Desktop Environment: Xfce 4.10

1
  • Xfce hardly any settings have been changed from default
    – ahtmatrix
    Commented May 13, 2013 at 23:59

2 Answers 2

18

Chromium obeys the system-wide xdg settings. To configure opening magnet links with a custom application use the following command

xdg-mime default transmission-gtk.desktop x-scheme-handler/magnet

You can also do this manually: Open the file ~/.local/share/applications/mimeapps.list and add the following entry in the section [Default Applications]:

x-scheme-handler/magnet=transmission-gtk.desktop

You can confirm the new setting with

xdg-mime query default x-scheme-handler/magnet
7
  • I did that however I still get 'Unable to to detect URI-scheme of'
    – ahtmatrix
    Commented May 13, 2013 at 11:33
  • 1
    @abacusasian What does the last command from my answer return?
    – Marco
    Commented May 13, 2013 at 17:39
  • @Marco, I tried your steps and although I get transmission-gtk.desktop as output from the xdg-mime command, nothing happens when I click on a magnet link in chrome.
    – slm
    Commented May 13, 2013 at 17:58
  • @Marco 'transmission-gtk.desktop'
    – ahtmatrix
    Commented May 14, 2013 at 0:05
  • @Marco I have the same problem abacusasian has, and your solution did not work :(
    – randunel
    Commented Jul 24, 2013 at 7:36
0

I had this problem with Debian Jessie, running the xfce desktop. It seems to be a bug in exo-open, which pops up a window saying "Unable to to detect URI-scheme of..." when asked to open a magnet link. Updating to the latest version of exo-utils solved the problem for me:

in debian:

sudo apt-get update
sudo apt-get install exo-utils

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .