0

My system configuration:

  • Processor: 12th gen Core i7 12700K x 20
  • 16 GB RAM
  • Not installed external GPU (No Graphics Card). All the GPU is from the processor itself (on chip)
  • Motherboard: Gigabyte B760M DS3H AX
  • Ubuntu version: 20.04.2 LTS
  • Running python version 3.8

I am running machine learning python code on my ubuntu desktop computer. Sometimes the python code runs smoothly but sometimes it halts (pauses) with the following kernel crash/ kernel panic:

How do I solve below error ? So, that my python code runs without any problem ?

Linux Ubuntu Kernel crash: python: Corrupted page table at address 4453d6d8. See image below:

enter image description here

How do I solve the above error ? So, that my python code runs without any problem ?

9
  • Does the kernel keep enjoying messages afterwards on what I guess is your serial console? Commented Sep 9, 2023 at 14:59
  • If this computer has no GPU, why is i915 loaded? That's an Intel GPU driver! Commented Sep 9, 2023 at 15:03
  • @MarcusMüller I think you can ignore the "No GPU" part. The board support a CPU iGPU and the CPU has an on chip gpu. I think the op is just a bit confused with that.
    – Bib
    Commented Sep 9, 2023 at 17:07
  • 1
    It's a hardware bug, replace RAM, if that doesn't help, replace CPU, if that doesn't help, replace mainboard. Next time use ECC memory. PS you may also check the memory first for bad addresses and black list these addresses in GRUB configuration
    – paladin
    Commented Sep 10, 2023 at 9:15
  • 1
    @Bib whoever is using a system with more than 8GiB of RAM for professional things and without ECC is doing stupid things in the first place, as you can see in OP posted problem. Intel just sucks, for disabling ECC in consumer hardware.
    – paladin
    Commented Sep 10, 2023 at 9:24

1 Answer 1

0

I had the same issue on Ubuntu 22.04.3 LTS Desktop version. After reinstalling OS to Ubuntu 22.04.1 LTS Desktop issues were not observed anymore. Python version installed to OS's were the same 3.10. Changing BIOS settings for the "Intel VID" function to the Disabled state fixed the issue in my case. Enter Bios ---> Advanced ---> Intel VID ---> Disable, in case of Acer laptops

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .