5

I've added the following line to my /etc/fstab to mount a ramdisk.

none /media/ramdisk tmpfs nodev,nosuid,noexec,nodiratime,size=2048M 0 0

It shows up in my desktop as a removable drive, and it is shown as such in the status bar and in the dock, as shown below.

Removable drive menu Removable drive in the dock

How can I disable this? Should I mount it with different options? Do I have to tweak some desktop settings?

I know that I could solve this by disabling the relative extensions, but I want "true" removable drives to show up there.

I don't think its related, but I'm using GNOME 44 on Fedora 38.

1 Answer 1

14

/media is intended for removable media, which is why your desktop environment shows the mountpoint as removable. To avoid that, mount your file system somewhere else, e.g. /mnt/ramdisk.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .