0

I'm using Mint 21 on an HP 17-y002na laptop. It's been connected via ethernet cable for much of the time since I updated to 21, but has had wifi capability at times. Last week I noticed that the symbol showing ethernet connection was absent from my panel, but wired connection still works. Unplugged, I get no wifi options or connection

Since then I have tried to sort it to no avail, and I think I may be doing more harm than good, so I'm asking for help. Current situation is:

iwconfig returns

lo        no wireless extensions.

eno1      no wireless extensions.

wlo1      IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

lspci -nnk | grep 0280 -A4 returns

03:00.0 Network controller [0280]: Broadcom Inc. and subsidiaries BCM43142 802.11b/g/n [14e4:4365] (rev 01)
    DeviceName: WLAN Broadcom 43142 bgn 1x1
    Subsystem: Hewlett-Packard Company BCM43142 802.11b/g/n [103c:804a]
    Kernel driver in use: wl
    Kernel modules: bcma, wl

'rfkill list all' returns

0: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no

The bluetooth unblocks when I select 'Turn Bluetooth On' in the panel, and the above command does then show 'Soft blocked: no'

'dmesg | grep wl' gives me

[   13.649275] wl: loading out-of-tree module taints kernel.
[   13.649291] wl: module license 'MIXED/Proprietary' taints kernel.
[   13.660611] wl: module verification failed: signature and/or required key missing - tainting kernel
[   13.877253] wlan0: Broadcom BCM4365 802.11 Hybrid Wireless Controller 6.30.223.271 (r587334)
[   14.674777] wl 0000:03:00.0 wlo1: renamed from wlan0

Wifi is (still) enabled in my BIOS/UEFI set up. Safe boot is disabled

Driver Manager shows I am using bcmwl-kernel-source version 6.30.223.271+bdcom-0ubuntu10~22.04.1

I do want to be able to use the laptop without having to be ethernet connected

Any information, advice or guidance appreciated. Thank you in advance,

Phil

Edit 1 - replaced output of all commands with current output

Edit 2 - I neglected to include all of the linux-header* i had showing as installed. These were: linux-headers-5.15.0-79

linux-headers-5.15.0-79-generic

linux-headers-5.15.0-82

linux-headers-5.15.0-82-generic

linux-headers-6.2.0-31-generic

linux-headers-generic

linux-headers-generic-hwe-20.04

linux-headers-generic-hwe-20.04-edge

linux-headers-generic-hwe-22.04

linux-headers-generic-hwe-22.04-edge

I have now uninstalled each of the 5.15.0-79* and 5.15.0-82* headers, as well as the linux-headers-generic-hwe-20.04* headers, and rebooted. Software manager informed me I needed to install 5.15.0-82* again, so I did, and uninstalled linux-headers-6.2.0-31-generic, which automatically removed the linux-headers-generic-hwe-22.04*. Rebooted again, and this time Software Manager didn't flag anything up. Still no wifi, but possibly getting closer to a solution?

2 Answers 2

0

The name of the outdated module is actually: cfg80211.ko.
Try dkms status, modprobe cfg80211 or insmod cfg80211.
It may be required to remove backport-iwlwifi-dkms ...

5
  • Thanks for replying. Tried to upvote but got notification 'Thanks for the feedback! You need at least 15 reputation to cast a vote, but your feedback has been recorded.' $ dkms status bcmwl/6.30.223.271+bdcom, 5.15.0-82-generic, x86_64: installed $ insmod cfg80211 insmod: ERROR: could not load module cfg80211: No such file or directory modprobe cfg80211 does not push a module to be used, so the output of lspci -nnk | grep 0280 -A4 remains as above sudo apt remove backport-iwlwifi-dkms returns Package 'backport-iwlwifi-dkms' is not installed, so not removed
    – Pine
    Commented Aug 31, 2023 at 11:17
  • Off the back of what you've said @Martin, thought I'd check for cfg80211.ko find / -iname 'cfg80211.ko' /usr/lib/modules/5.15.0-79-generic/kernel/net/wireless/cfg80211.ko /usr/lib/modules/5.15.0-76-lowlatency/kernel/net/wireless/cfg80211.ko /usr/lib/modules/5.15.0-82-generic/kernel/net/wireless/cfg80211.ko /usr/lib/modules/5.15.0-82-generic/ubuntu/iwlwifi/cfg80211.ko So do I need to remove those modules that 5.15.0-82-generic? And can you recommend a 'best way' to remove them?
    – Pine
    Commented Aug 31, 2023 at 12:11
  • It seems to use bcmwl driver. And error message looks alike a library version conflict; sudo apt-get install --reinstall linux-headers`uname -r` dkms build-essential bcmwl-kernel-source. Commented Aug 31, 2023 at 20:19
  • I think you're onto something there. The command given returns 'E: Unable to locate package linux-headers5.15.0-82-generic E: Couldn't find any package by glob 'linux-headers5.15.0-82-generic' E: Couldn't find any package by regex 'linux-headers5.15.0-82-generic' , which suggests it is looking for something it needs, but if I search for that in package manager nothing shows up
    – Pine
    Commented Sep 1, 2023 at 8:03
  • Looked for linux-headers,all these show as installed linux-headers-5.15.0-79: installed version 5.15.0-79.86 linux-headers-5.15.0-79-generic: installed version 5.15.0-79.86 linux-headers-5.15.0-82: installed version 5.15.0-82.91 linux-headers-5.15.0-82-generic: installed version 5.15.0-82.91 linux-headers-6.2.0-31-generic: 6.2.0-31.31~22.04.1 linux-headers-generic: 5.15.0.82.78 linux-headers-generic-hwe-20.04: 5.15.0.82.78 linux-headers-generic-hwe-20.04-edge: 5.15.0.82.78 linux-headers-generic-hwe-22.04: 6.2.0-31.31~22.04.8 linux-headers-generic-hwe-22.04-edge: 6.2.0-31.31~22.04.8
    – Pine
    Commented Sep 1, 2023 at 8:35
0

After running

sudo apt remove bcmwl-kernel-source && sudo apt install --reinstall broadcom-sta-dkms

sudo modprobe -rv bcma wl

and

sudo modprobe -v wl,

then rebooting, still no wifi icon or connection, but I hit on the idea of running terminal commands to see what could be seen

 nmcli dev wifi

listed networks I could try connecting to, then

 nmcli dev wifi connect <name> password <password>

(put a space at the start of the command to not store details in bash history ) with the appropriate details got me connected and working

Still no icon in the panel, and I don't know if it will survive a reboot, but this is definite progress and I'm going to mark this as solved. I'll add more if I find a) a more persistent solution is needed, and b) a more persistent solution

edit - nmcli con up <network> works if authentication details are already present, and is persistent

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .