0

Today I faced serious bug while using kazam (screen recorder) on fedora 38 workstation. The bug was unavailability to stop recording.

I tried to reinstall it by running in terminal sudo dnf reinstall kazam, but dnf answered me the following:

Last metadata expiration check: 0:08:16 ago on Tue 29 Aug 2023 06:29:53 PM EET.
Package kazam available, but not installed.
No match for argument: kazam
Error: No packages marked for reinstall.

so, dnf could't find corresponding package

after that I tried delete the package trough built-in fedora software manager, but also couldn't find package 'kazam'

then, I tried to run sudo rpm -qa | grep kazam to fild the target package, nothing returned

sudo yum list installed | grep kazam finished with the same result - nothing

snap and flatpak also do not list kazam.

But kazam is starting! Where could i loose it? and how to delete kazam, if i cannot find it anywhere?

2
  • 1
    so, you didn't install it via dnf, rpm, flatpak nor snap. So, you must have installed it another way. This is your system, we can't guess what you manually did! Aug 29, 2023 at 17:29
  • I am not so advanced linux user to install something manually. And this is the reason why I install everything using package managers. But anyway thank you for comment, from now I will be more accurate doing anything manually with system! Aug 29, 2023 at 17:46

1 Answer 1

0

The problem was solved by installing kazam from one of third-party RPM repos. After this action, package managers began to understand that kazam is installed.

More detailed process:

sudo dnf install https://raw.githubusercontent.com/rpmsphere/noarch/master/r/rpmsphere-release-38-1.noarch.rpm
sudo dnf update && sudo dnf install kazam
sudo dnf remove kazam
sudo dnf autoremove

I faced the same issue on laptop also powered by fedora, but the same manipulations didn't work in this case

1
  • That just means you put a second installation there, which might, or might not, have contained exactly the same files as whatever you had installed Aug 30, 2023 at 2:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .