1

We have our company server, where we connect using ssh and private key. There we have oracle wallet manager (owm), but it can only be run using Xserver. If I setup putty in windows, allow x11 forwarding with address localhost:0.0, it works fine. But I was trying to accomplish that through wsl. What I was able to do, is that I can ping now between windows and wsl, I can connect to our working server using ssh <username>@<servername> -p 22 -i /path_to_certificate/certificate_name.pem, but from there, I am stuck.

I was trying to set DISPLAY variable to windows machine IP address:0.0, to wsl address and all combinations I could try, but still nothing. I have enabled X11 forwarding in /etc/ssh/sshd_config.

Does anyone have Idea, if this is even possible?

1 Answer 1

1

/etc/ssh/sshd_config is responsible for the server side, and it only specifies whether X11 forwarding is permitted on the server (and would only have effect on the destination server, the one you ssh to).

But you should also enable it on the client side on your WSL via /etc/ssh/ssh_config. You need to add the following to allow X11 forwarding by default:

ForwardX11 yes

You can also add the -X flag to your ssh command (Enables X11 forwarding) if you don't want to allow this by default. You can try this first as a test, and if it works you can change your ssh_config.

Don't forget to set your DISPLAY to localhost:0.0 on your WSL client before performing the ssh.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .