2

I was trying to upgrade a VPS from Buster to Bookworm.

I followed these steps:

   44  20/Aug - 21:26:11 sudo apt update && sudo apt upgrade -y
   45  20/Aug - 21:26:38 sudo apt --purge autoremove
   46  20/Aug - 21:26:48 sudo vi /etc/apt/sources.list
   47  20/Aug - 21:27:48 sudo apt update
   48  20/Aug - 21:29:05 sudo vi /etc/apt/sources.list
   49  20/Aug - 21:29:38 sudo apt update
   50  20/Aug - 21:30:15 sudo apt upgrade --without-new-pkgs -y
   51  20/Aug - 21:32:36 sudo apt full-upgrade -y

The extra edit to the sources.list was to handle the new Security repos structure.

The upgrade failed with the error:

Setting up libc6:amd64 (2.36-9+deb12u1) ...
/usr/bin/perl: error while loading shared libraries: libcrypt.so.1: cannot open shared object file: No such file or directory
dpkg: error processing package libc6:amd64 (--configure):
 installed libc6:amd64 package post-installation script subprocess returned error exit status 127
Errors were encountered while processing:
 libc6:amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)

In attempting to debug/resolve the issue I'm finding I can no longer sudo / access the root account (password login to root is disabled). I get an error of:

$ sudo su
sudo: account validation failure, is your account locked?

Any ideas?

3
  • 3
    What happened to Buster -> Bullseye -> Bookworm? Unfortunately you should have upgraded one release at a time Aug 20, 2023 at 20:49
  • @roaima thank you - I googled upgrade Buster to Bookworm and the first result took me into the steps (but I failed to read the title). My bad. Thank you, I'll rebuild the VPS and do it one release at a time.
    – steve
    Aug 20, 2023 at 21:10
  • FWIW, this exact thing happened to me too. Seems unrecoverable sadly.
    – Min
    Nov 23, 2023 at 0:13

0

You must log in to answer this question.

Browse other questions tagged .