0

i have followed posts on Network Manager looping to connect to enterprise networks and coming back again and again asking for logon/password. the answer seems to be to use wpa_supplicant.

i did a log file extract to confirm the process and got ...supplicant interface state: disconnected -> interface_disabled...

there is a directory at /etc/wpa_supplicant, but there is no wpa_supplicant config file. the only files listed are action_wpa.sh functions.sh ifupdown.sh i guess that there are a few things i need to do?

some perspective here: i am just trying to learn python, using an excellent on-line course from 'degreed' at work and doing the exercises on an old 32bit laptop running mx-linux and a compatible 32bit version of PyCharm Community Edition. my knowledge of network stuff can't fill the bottom of a thimble. so feel free to assume i haven't found the beginning of the string on this issue with logging in. any suggestions at starting points would be appreciated. thanks, ron

ron@9-LPTOP:~
$ sudo journalctl -fu NetworkManager
[sudo] password for ron: 
-- Journal begins at Tue 2023-01-24 14:43:06 EST. --
Jan 24 14:55:54 9-LPTOP NetworkManager[598]: <info>  [1674590154.0956] device (wlan0): supplicant interface state: disconnected -> interface_disabled
Jan 24 14:55:54 9-LPTOP NetworkManager[598]: <info>  [1674590154.0957] modem-manager: ModemManager no longer available
Jan 24 14:55:54 9-LPTOP NetworkManager[598]: <info>  [1674590154.1027] device (wlan0): supplicant interface state: interface_disabled -> disconnected
Jan 24 14:55:54 9-LPTOP systemd[1]: Stopping Network Manager...
Jan 24 14:55:54 9-LPTOP NetworkManager[598]: <info>  [1674590154.5312] caught SIGTERM, shutting down normally.
Jan 24 14:55:54 9-LPTOP NetworkManager[598]: <info>  [1674590154.5338] device (wlan0): state change: disconnected -> unmanaged (reason 'unmanaged', sys-iface-state: 'managed')
Jan 24 14:55:54 9-LPTOP NetworkManager[598]: <info>  [1674590154.5468] device (wlan0): set-hw-addr: reset MAC address to 00:19:D2:05:A7:9D (unmanage)
Jan 24 14:55:54 9-LPTOP NetworkManager[598]: <info>  [1674590154.6549] exiting (success)
Jan 24 14:55:54 9-LPTOP systemd[1]: NetworkManager.service: Succeeded.
Jan 24 14:55:54 9-LPTOP systemd[1]: Stopped Network Manager.
3
  • 2
    Your log snippet is from January 24, so either the system's clock is wildly off or this log snippet is most likely obsolete information. NetworkManager could automatically configure wpa_supplicant for you if it is available in the system, but it seems the interface has been set into "unmanaged" state in NetworkManager, i.e. NetworkManager has been told to ignore that interface. I would recommend nmcli d set wlan0 managed yes to undo that, to re-allow the use of NetworkManager tools to ease configuration... unless you specifically want to do this the hard way?
    – telcoM
    Aug 19, 2023 at 7:49
  • telcoM, very very much appreciate your help - was out a few days and now back on the case. i may never learn python - but learning lots of other things. OK-date/time-correct. i discovered i boot w/'init' and not systemd. now i know how to boot w/systemd. i did validate that the driver is NetworkManager. SO, tomorrow, at work, i will try and do journalctl again. now, under systemd, does your nmcli command work? if i do sudo nmcli..., is that a command that functions in systemd? i tried it a home, while logging into my home network, but the journal doesn't show any results.
    – rny1so
    Aug 28, 2023 at 23:56
  • telcoM - here is what i get with $ sudo service NetworkManager status ● NetworkManager.service - Network Manager Loaded: loaded (/lib/systemd/system/NetworkManager.service; enabled; vendor preset: enabled) Active: active (running) since Mon 2023-08-28 17:12:38 EDT; 3min 59s ago Docs: man:NetworkManager(8) Main PID: 599 (NetworkManager) Tasks: 3 (limit: 4915) Memory: 10.4M CPU: 475ms CGroup: /system.slice/NetworkManager.service └─599 /usr/sbin/NetworkManager --no-daemon etc etc. SO next step is initiating a daemon? yes?
    – rny1so
    Aug 28, 2023 at 23:58

1 Answer 1

0

You already have NetworkManager running. If you let it control your wlan0 interface, it will configure and start wpa_supplicant automatically for you. That would be the most user-friendly way forward; using wpa_supplicant directly would probably be extremely challenging for you, as you admitted you don't know much about "network stuff".

But your log snippet from January indicates the wlan0 interface is unmanaged by NetworkManager - i.e. NetworkManager has apparently been told not to touch it. To tell NetworkManager to assume control of wlan0, run:

sudo nmcli d set wlan0 managed yes

After that, you should be able to use any NetworkManager user interfaces to configure your wlan0.

nmcli is a command-based user interface to NetworkManager, but there are probably graphical interface tools in your MX Linux too, but without knowing which desktop environment (XFCE? KDE? Fluxbox?) you are using, I cannot point you at them, sorry.

In the question title, you said you don't have a CA certificate. If your enterprise network uses a public CA, then you can just try leaving the "CA certificate" field in the WiFi configuration empty - NetworkManager will then automatically use any applicable CA certificates available in the standard system CA certificate directory, /etc/ssl/certs/.

Accepting any public CA certificate is a bit less secure than accepting just the specific one that is expected to be used by your enterpise's WiFi network. It means an attacker would have one less hurdle in setting up a fake "enterprise" access point to capture your WiFi authentication information.

But if your enterprise WiFi network uses a private CA (e.g. the built-in CA of a Windows Active Directory domain), then you will need to get the CA certificate first. You won't need the private key of the CA certificate - just the public part. You would have to either copy it from any other computer that is already connected to the enterprise WiFi network, or ask your enterprise IT support to give you a copy of the CA certificate.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .