0

I bought a mechanical USB keyboard that use RGB stuff to indicate the state of lock keys (and other eye candy).

It works fine, except with a minor problem: caps lock indicator works in reverse, therefore when it's OFF, the keyboard types capitals, when it's ON the keyboard types lower case.

If I connect a second standard keyboard to the PC that second keyboard indicates Caps lock state correctly. So it's not a system-wide problem, but specific to the keyboard.

If I boot into Windows, the indicator led works properly. So I guess this has something to do with the keyboard drivers.

I can live with it by setting a color scheme such that the caps lock blends in... But that's not an ideal solution.

The keyboard doesn't come with software to control RGB. It can be configured entirely by using the combinations of the FN key.

Is there any way to fix this? Where should I look?

lsusb identifies it as ID 1a2c:1502 China Resource Semico Co., Ltd RGB Gaming KB

3
  • Are you using X11 or Wayland? Is it ok to disable capslock?
    – meuh
    Commented Aug 11, 2023 at 8:40
  • @meuh X11. I'd like keep the caps look if possible.
    – Calmarius
    Commented Aug 12, 2023 at 22:28
  • You might be able to turn off the led with xset -led named "Caps Lock", until the next time you hit the key. You could ignore the caps lock with setxkbmap -option caps:none. The vendor:product id of the kbd doesnt seem to have made it into the db of ids, so is unlikely to have any fixes in /lib/udev/hwdb.d/, or the kernel quirks fixes for hid kbds.
    – meuh
    Commented Aug 13, 2023 at 17:13

0

You must log in to answer this question.

Browse other questions tagged .