1

I have installed Fedora IOT 38 on an offline server and I'm attempting to install an RPM package. However, I'm encountering the following error:

# rpm-ostree install k3s-selinux-1.4-1.coreos.noarch.rpm
Checking out tree 5dcb22f... done
Enabled rpm-md repositories: fedora-cisco-openh264 updates fedora
Updating metadata for 'fedora-cisco-openh264'... done
error: Updating rpm-md repo 'fedora-cisco-openh264': cannot update repo 'fedora-cisco-openh264': Cannot prepare internal mirrorlist: Curl error (6): Couldn't resolve host name for https://mirrors.fedoraproject.org/metalink?repo=fedora-cisco-openh264-38&arch=x86_64 [Could not resolve host: mirrors.fedoraproject.org]; Last error: Curl error (6): Couldn't resolve host name for https://mirrors.fedoraproject.org/metalink?repo=fedora-cisco-openh264-38&arch=x86_64 [Could not resolve host: mirrors.fedoraproject.org]

Any hint to bypass this error.

1
  • Does adding --cache-only help? I think that should skip that failing metadata update. I haven't tested, so just making this a comment -- but I'll change it to an answer if it works!
    – mattdm
    Aug 21, 2023 at 15:31

1 Answer 1

0

I have to disable repos like below and it works

sed -i "s/enabled=1/enabled=0" /etc/yum.repos.d/*.repo

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .