When I installed Debian 12, I was given the option to not allow root logins. Instead, the system lets me use su each time I need to do some minor maintenance.

When I go to http://localhost:631/, however, the login to administor passwords doesn't work. I tried username + password and "root" + password for usually sudo-ing, but neither worked.

How can I log into CUPS on Debian to administer my printers when root access is disabled?

  • 1
    With no guarantee of any sort : Try editing /etc/cups/cupsd.conf, find teh plave were SystemGroup is defined. It should show some group name. Normally lpadmin. If it shows lpadmin then simply add root (user) to the lpadmin group. If it shows nothing then add lpadmin, eventually create the lpadmin group and add root in the lpadmin group.
    – MC68020
    Aug 6, 2023 at 18:30
  • Rather than add root, I believe the commentor means add sudo user to lpadmin' Usually adding the user to the lp` group will work no matter what.
    – Brian
    Aug 6, 2023 at 21:43

1 Answer 1


from cups-files.conf(5):

SystemGroup group-name [ ... group-name ]

Specifies the group(s) to use for @SYSTEM group authentication. The default contains "admin", "lpadmin", "root", "sys", and/or "system".

The cups-daemon package on Debian ships with a default for /etc/cups/cups-files.conf of:

SystemGroup root lpadmin

(most probably from compilation options)

One can authenticate with an user in this group on the web page to gain administrative privileges through the CUPS GUI.

So this will be enough:

sudo adduser $USER lpadmin

Now after being authenticated using $USER and its password in the web session (even if authentication has already been done in the current web session and led to a Forbidden message), the administrative web menus are accessible (logout/login of the desktop user is not even needed: this is over TCP, so there's no local user credential considered, only the target user is considered).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .