1

I have a samba v4.17.5 server working well, I can browse all of the shares from Win 10 clients. The clients and the samba host are members of a domain.

However, when I try to browse the samba server from a Win 2019 server, I get error 0x80070035. The Network "Security:LAN Manager authentication level" is set to "Send NTLMv2 response only. Refuse LM & NTLM" on the Win 2019 server.

My samba server's smb.conf leaves at default (not configured in conf) the following:

  • lanman auth
  • ntlm auth
  • server signing

so the Samba server should be using NTLMv2 by default.

I'm not sure what is causing this. If I browse to the samba server from the win2019 server using the samba server's IP address I get error 0x80004005. I suspect this is NTLM related but I can't figure it out.

Based on this post I tried entering a un/pw into the windows credentials manager on the Win2019server. Interestingly, when I try to browse to the samba host I now get a credentials challenge (popup to enter credentials) but all credentials are refused, even valid local accounts on the samba host.


UPDATE: I realize I was logged into the Win2019server as domain administrator. And for some reason that made samba refuse the connection. I tried the solution described here (adding "min domain uid = 0" to smb.conf) and all started to work!

Can someone explain what this accomplished?

4
  • 0x80070035 means that the client can't find the network path that is being entered whereas 0x80004005 is ambiguous in regards to accessing a file share. When it comes to entering credentials, are they credentials for a Samba user who has access to the SMB share(s) that you are trying to access? Also, have you looked at the logs on the Samba server? Aug 6, 2023 at 14:44
  • When prompted I entered credentials for an account local to the Samba host. I have not created samba users - I assume valid local host credentials should work. But this does feel like a workaround...the Win2019server should be able to browse the samba shares.
    – TSG
    Aug 6, 2023 at 14:54
  • My mistake. You said that they are members of a domain. In that case, are you using credentials for an account that has access to the Samba shares? Aug 6, 2023 at 15:13
  • Hint, these errors when they start with 0x8007 and four more hex digits, refer to a Win32 error code. That is, you can use the decimal version of the hexadecimal code (0x35 -> decimal 53) and look it up in winerror.h or online. The 7 in the 0x8007 literally stands for Win32 and is called a facility code. Aug 6, 2023 at 15:19

1 Answer 1

0

They probably want to keep admins out, to prevent wrecking everything accidentally.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .