0

When I run

firefox --new-window <url> &

Firefox starts. When I run it again, I get an error dialog reading:

Firefox is already running, but is not responding. To use Firefox, you must first close the existing Firefox process, restart your device, or use a different profile.

The expected behavior is that a second window opens on the same web page.

How do I fix this?

Note that I do not want instructions on how to kill the existing Firefox, or to remove lock files. Everything else about it is working fine. It just isn't taking the remote command.

3
  • Do you use multiple profiles with firefox ? Maybe you have multiple instances of firefox running ? Maybe the problem is related with the OS ?
    – Marco
    Commented Jul 26, 2023 at 15:32
  • @Marco After the first failure, I deleted all profiles and made a new one. No help. Made a second profile, no help. OS issues? maybe, but what should I try?
    – David G.
    Commented Jul 26, 2023 at 16:06
  • Unfortunately I don't know how firefox handles this and it works on my system. Ask somebody of the firefox developer or try debugging it: firefox-source-docs.mozilla.org
    – Marco
    Commented Jul 27, 2023 at 11:55

1 Answer 1

0

It turns out that they replaced the classic X-based ICCCM-conformant open URL command with something dbus based.

So if you remove dbus, you get this error.

Pity.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .