0

I removed the flags 'quiet' , 'splash' , and added others in the file /etc/default/grub, applied them: grub2-mkconfig -o . After a reboot, the kernel boot flags began to double. With each 'grub2-mkconfig -o ' command and reload the number of options increases. An entry 'unknown parameters' appeared in the log. OS - Fedora 38. Screenshot of the log in the link below.

/etc/default/grub

GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_DISABLE_SUBMENU=true
GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX="rhgb tsc=unstable & trace_clock=local"
GRUB_DISABLE_RECOVERY="true"
GRUB_ENABLE_BLSCFG=true
GRUB_CMDLINE_LINUX_DEFAULT="rhgb splash initcall_blacklist=amd_pstate_init amd_pstate.enable=0 tsc=unstable & trace_clock=local"


cat /proc/cmdline

BOOT_IMAGE=(hd0,gpt2)/vmlinuz-6.3.12-200.fc38.x86_64 root=UUID=eba5bfa3-0cef-458d-ad0c-b629bfd7538e ro rootflags=subvol=root rhgb tsc=unstable options root=UUID=eba5bfa3-0cef-458d-ad0c-b629bfd7538e ro rootflags=subvol=root rhgb tsc=unstable options root=UUID=eba5bfa3-0cef-458d-ad0c-b629bfd7538e ro rootflags=subvol=root rhgb rd.plymouth=0 plymouth.enable=0 tsc=unstable options root=UUID=eba5bfa3-0cef-458d-ad0c-b629bfd7538e ro rootflags=subvol=root rhgb rd.plymouth=0 tsc=unstable options root=UUID=eba5bfa3-0cef-458d-ad0c-b629bfd7538e ro rootflags=subvol=root rhgb tsc=unstable options root=UUID=eba5bfa3-0cef-458d-ad0c-b629bfd7538e ro rootflags=subvol=root rhgb quiet trace_clock=local trace_clock=local trace_clock=local trace_clock=local trace_clock=local rhgb splash initcall_blacklist=amd_pstate_init amd_pstate.enable=0 tsc=unstable options root=UUID=eba5bfa3-0cef-458d-ad0c-b629bfd7538e ro rootflags=subvol=root rhgb tsc=unstable options root=UUID=eba5bfa3-0cef-458d-ad0c-b629bfd7538e ro rootflags=subvol=root rhgb rd.plymouth=0 plymouth.enable=0 tsc=unstable options root=UUID=eba5bfa3-0cef-458d-ad0c-b629bfd7538e ro rootflags=subvol=root rhgb rd.plymouth=0 tsc=unstable options root=UUID=eba5bfa3-0cef-458d-ad0c-b629bfd7538e ro rootflags=subvol=root rhgb tsc=unstable options root=UUID=eba5bfa3-0cef-458d-ad0c-b629bfd7538e ro rootflags=subvol=root rhgb quiet trace_clock=local trace_clock=local trace_clock=local trace_clock=local trace_clock=local

Output of the kernel boot log:
https://drive.google.com/file/d/1-eohEvSaf6_6f5s0-qd39J2tvaXhcysv/view?usp=sharing

How can i fix this?

1
  • Please clarify your specific problem or provide additional details to highlight exactly what you need. As it's currently written, it's hard to tell exactly what you're asking.
    – Community Bot
    Jul 21, 2023 at 15:59

1 Answer 1

0

Solved after kernel update to 6.4.4 version! Boot settings are configured correctly. There are no duplicates.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .