0

I'm a Linux newbie. I recently installed Pop!_OS 22.04 because of its hybrid graphic driver. The problem is that when I open the Android Studio emulator, the system audio starts to crackle and there is a ticking sound whether when the audio is played by the emulator or other applications.

There are some backgrounds to this. I had been using the system like this for a month now and the problem got worse. Even when the emulator was not running, the audio crackling continued. Turns out, one of my speakers gave up (front-right), and I suspect this issue to be the culprit.

I thought the problem was with the sound driver, so I tweaked and tried everything I found on the web, and I may have changed ALSA, PulseAudio, or PipeWire configs. Therefore, a full reset of sound drivers would be much appreciated.

I believe providing the Android emulator config would also help:

  1. RAM Size: 2048 MB

  2. Heap Size: 228 MB

  3. Multicore CPU: 4

Thanks.

1
  • i have changed the balance to use the left speaker for now but i fear the same happens to left speaker as well
    – R3HP
    Jul 18, 2023 at 14:00

1 Answer 1

0

I had the same issue with the Android emulator and what worked for me was what I found in this Reddit post.

I was listening to music and I had that issue when the emulator was opened, then I ran

systemctl --user restart pipewire.service

I waited a few seconds and the audio for every program was fine.

You can check all the rest of the post, because for some people what worked was to restart more services:

systemctl --user restart wireplumber pipewire pipewire-pulse
1
  • Hi,tnx for the answer . i tried a commnads you mentioned after running the emulator , the sound gets fixed and the ticking is gone but emulator sound is also gone.
    – R3HP
    Aug 8, 2023 at 12:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .