When I use depmod in the terminal, I got the message "depmod command not found". But kmod is already installed. And I can find a link to something called depmod in sbin. Do you know how to solve this?

I use Debian 11 GNOME.

1 Answer 1


Option 1

Check the depmod command location:

ls -l /sbin/depmod

If the link is broken, you can recreate it using the following command:

sudo ln -s /usr/bin/depmod /sbin/depmod

How can I "relink" a lot of broken symlinks?

How can I find broken symlinks

Option 2

Check if you can call depmod with /sbin/depmod

Check if the /sbin directory is included in your system's PATH variable

echo $PATH

If it's not, you can add it temporarily to your current session:

export PATH=$PATH:/sbin

To make this permanent, add the line export PATH=$PATH:/sbin to the end of your ~/.bashrc file

What are PATH and other environment variables, and how can I set or use them?

Add /usr/local/sbin to the PATH of a user

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .