1

I need to install minimal openbox system on Debian 12:

apt-get --no-install-recommends install openbox

and apt-get wants to install, among other packages:

libavahi-client3 libavahi-common-data libavahi-common3 

apt-cache show openbox does not show avahi monstrosity as dependency:

Depends: libc6 (>= 2.14), libglib2.0-0 (>= 2.35.9), libice6 (>= 1:1.0.0), libobrender32v5 (>= 3.6.0), libobt2v5 (>= 3.6.0), libsm6, libstartup-notification0 (>= 0.7), libx11-6, libxau6 (>= 1:1.0.9), libxcursor1 (>> 1.1.2), libxext6, libxi6 (>= 2:1.2.99.4), libxinerama1, libxrandr2, python3

so, presumably some dependnecy of a dependency of a dependency wants to install it. How can i find the package that depends on avahi?

1 Answer 1

1

Ask aptitude:

$ aptitude why openbox libavahi-client3
p   openbox         Depends libobrender32v5 (>= 3.6.0)  
p   libobrender32v5 Depends libimlib2 (>= 1.4.5)        
p A libimlib2       Depends libspectre1 (>= 0.2.3)      
p A libspectre1     Depends libgs10 (>= 9.53.0~dfsg)    
p   libgs10         Depends libcups2 (>= 2.3~b6)        
p A libcups2        Depends libavahi-client3 (>= 0.6.16)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .