What rescue disk (rescue CD/DVD) would you recommend for an user which unfortunately needs to rescue data from a bad disk (filesystems does not mount when using LiveCD, though fdisk looks O.K.) for a very first time?

System does not boot from HDD: grub prints

error: attempt to read or write outside of disk 'hd0'
grub rescue>

When trying to use e2fsck, or mount filesystem, or just list metadata with tune2fs I get:

$ sudo tune2fs -l /dev/sda6
tune2fs 1.42.5 (29-Jul-2012)
tune2fs: Attempt to read block from filesystem resulted in short read
         while trying to open /dev/sda6
Couldn't find valid filesystem superblock.

Fortunately booting from LiveCD works (I am writing this from Lubuntu 12.10 LiveCD).


We've used HDAT2 and Spinrite for several HDDs recoveries. Both have worked well. We were particularly impresses with HDAT2's ability to recover a HDD enough so that we could use Clonezilla to copy the HDD to another HDD. Spinrite was unsuccessful on that particular drive, but has recovered drives for us in the past.

screenshots of HDAT2

   ss hdat2 #1

   ss of hda2 #2

Both of these are meant for offline recovery, so you typically burn them to a CD and/or USB thumbdrive and boot a system with them.


I tend to use SysRescueCD. It contains many tools that I find useful for recovering data, like ddrescue and testdisk.


Have used Hiren's Boot CD from time to time.

Click "See CD Contents" towards bottom of page (below download link) to see software included.


Give this thing a try. Costs $$, but he will give you your money back if it doesn't work.


I tried it and it worked. My brother in law tried it and it didn't work. He got his money back easily. YMMV, but I was impressed.


I'd try copying the disk contents to a good disk, and make copies of that to fool around. Messing with damaged disks is a sure-fire way of damaging them even more, eventually making data rescue impossible.

If the data is valuable enough, consider a data recovery service (then again, it isn't, as you have no backups...).

  • Filesystems on this disk does not mount, so 'try copying the disk contents to a good disk' is a bit unhelpful advice; I'll try using rescue disk tools to recover dta to external disk. – Jakub Narębski May 9 '13 at 5:50
  • @JakubNarębski, copy the disk, not the filesystems. – vonbrand May 9 '13 at 11:01
  • @JakubNarębski ddrescue copies the raw binary data from the disk - no need to mount it - just check with fdisk -l where it is connected – Amir Uval Jul 13 '13 at 21:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.