1

I have a laptop with Arch Linux using NetworkManager. Every time I close the lid, WiFi gets disabled (rfkill shows "soft blocked").

I have tried everything: disabling powersave, reinstalling NetworkManager...

Here's my journal:

Jul 13 19:44:40 commondevice systemd-logind[271]: Lid closed.
Jul 13 19:44:40 commondevice kernel: wlo1: deauthenticating from 50:d2:f5:2c:d0:e0 by local choice (Reason: 3=DEAUTH_LEAVING)
Jul 13 19:44:40 commondevice wpa_supplicant[283]: wlo1: CTRL-EVENT-DISCONNECTED bssid=50:d2:f5:2c:d0:e0 reason=3 locally_generated=1
Jul 13 19:44:40 commondevice wpa_supplicant[283]: rfkill: WLAN soft blocked
Jul 13 19:44:40 commondevice NetworkManager[2125]: <info>  [1689266680.9394] manager: rfkill: Wi-Fi now disabled by radio killswitch
Jul 13 19:44:40 commondevice NetworkManager[2125]: <info>  [1689266680.9396] device (wlo1): state change: activated -> unavailable (reason 'none', sys-iface-state: 'managed')
Jul 13 19:44:40 commondevice NetworkManager[2125]: <info>  [1689266680.9534] dhcp4 (wlo1): canceled DHCP transaction
Jul 13 19:44:40 commondevice NetworkManager[2125]: <info>  [1689266680.9535] dhcp4 (wlo1): activation: beginning transaction (timeout in 45 seconds)
Jul 13 19:44:40 commondevice NetworkManager[2125]: <info>  [1689266680.9535] dhcp4 (wlo1): state changed no lease
Jul 13 19:44:40 commondevice systemd[1]: Starting Load/Save RF Kill Switch Status...
Jul 13 19:44:40 commondevice systemd[1]: Started Load/Save RF Kill Switch Status.
Jul 13 19:44:40 commondevice systemd-logind[271]: Lid opened.
Jul 13 19:44:41 commondevice NetworkManager[2125]: <info>  [1689266681.1575] manager: NetworkManager state is now DISCONNECTED
Jul 13 19:44:41 commondevice wpa_supplicant[283]: wlo1: CTRL-EVENT-DSCP-POLICY clear_all
Jul 13 19:44:41 commondevice dbus-daemon[270]: [system] Activating via systemd: service name='org.freedesktop.nm_dispatcher' unit='dbus-org.freedesktop.nm-dispatcher.service' requested by ':1.74' (uid=0 pid=2125 comm="/usr/bin/NetworkManager --no-daemon")
Jul 13 19:44:41 commondevice systemd[1]: Starting Network Manager Script Dispatcher Service...
Jul 13 19:44:41 commondevice wpa_supplicant[283]: wlo1: CTRL-EVENT-DSCP-POLICY clear_all
Jul 13 19:44:41 commondevice wpa_supplicant[283]: nl80211: deinit ifname=wlo1 disabled_11b_rates=0
Jul 13 19:44:41 commondevice dbus-daemon[270]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
Jul 13 19:44:41 commondevice systemd[1]: Started Network Manager Script Dispatcher Service.
Jul 13 19:44:45 commondevice systemd[1]: systemd-rfkill.service: Deactivated successfully.
Jul 13 19:44:48 commondevice dbus-daemon[270]: [system] Activating via systemd: service name='org.freedesktop.home1' unit='dbus-org.freedesktop.home1.service' requested by ':1.92' (uid=1000 pid=2658 comm="/usr/lib/xfce4-screensaver-dialog --monitor=0 --he")
Jul 13 19:44:48 commondevice dbus-daemon[270]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.home1.service': Unit dbus-org.freedesktop.home1.service not found.
Jul 13 19:44:48 commondevice xfce4-screensaver-dialog[2658]: pam_systemd_home(xfce4-screensaver:auth): systemd-homed is not available: Unit dbus-org.freedesktop.home1.service not found.
Jul 13 19:44:48 commondevice rtkit-daemon[484]: Supervising 4 threads of 2 processes of 1 users.
Jul 13 19:44:48 commondevice rtkit-daemon[484]: Supervising 4 threads of 2 processes of 1 users.
Jul 13 19:44:51 commondevice xfce4-screensaver-dialog[2658]: gkr-pam: unlocked login keyring
Jul 13 19:44:51 commondevice xfce4-screensaver-dialog[2658]: pam_warn(xfce4-screensaver:account): function=[pam_sm_acct_mgmt] flags=0 service=[xfce4-screensaver] terminal=[:0.0] user=[mrvoid] ruser=[<unknown>] rhost=[<unknown>]
Jul 13 19:44:51 commondevice systemd[1]: NetworkManager-dispatcher.service: Deactivated successfully.

2 Answers 2

0

If you don't ever need to disable the wifi using the physical switch, you could try blacklisting the rfkill module? Perhaps try removing it first with modprobe -r rfkill, to see if that prevents the blocking behavior when you close the lid?

(I'm sure there is a better way to do it, but this might work as a quick-fix)

1
  • (I will edit to improve the answer, if it works)
    – Time4Tea
    Commented Jul 14, 2023 at 14:49
0

If don't need to dig into the issue,
you can use [tlp][1] software with which you can "force" wifi power on at startup


[1] https://github.com/linrunner/TLP

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .