0

On a HP ZBook G6 with two Kingston M.2 NVMe SSDs is Windows running without problems. But when booting the Debian 12 installer ISO from an USB hard disk, the Linux 6.0 kernel does not detect these NVMe disks but detects only the USB boot disk in /proc/partitions.

I tried modprobe nvme-core nvme nvmet but the repeated Debian installer "Detect disks" still does not detect these. (The installer ISO initrd does not contain a partprobe executable so I did not try that.) lspci does not show anything about NVMe.
Same result with the default graphical install and the text mode experts installer.

What can I do to detect the NVMe disks ?

Edit: Updating the BIOS and disabling Secure Boot did not help. Hardware RAID is disabled.

2
  • I've read after searching for your issue using a so-called search engine, that you'd need to disable secure boot in the BIOS - YMMV if you search the internets for the phrase installing linux on HP ZBook G6 Commented Jul 14, 2023 at 0:16
  • Have you updated UEFI firmware & if NVMe drive, updated its firmware? Some settings on another zBook: ubuntuforums.org/showthread.php?t=2482555&page=2
    – oldfred
    Commented Jul 14, 2023 at 2:37

2 Answers 2

1

The problem was caused by the enabled but unused BIOS option Storage Controller for Intel Optane (there is no Optane memory in the system in question).

Disabling this BIOS setting shows a warning about possible data loss and accepting this warning allows the NVMEs to be recognized, in fact without data loss.

As long as that Optane option was on, the Linux kernel produced a false warning in dmesg about active hardware RAID (which is available, but has never been enabled). A second line suggested disabling this hardware RAID to get access to the NVMe SSDs.

0

I had a similar problem on a Dell OptiPlex Mini PC. Solved it by changing from RAID ON to AHCI in the BIOS Hard Drive settings.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .