3

Ever since moving to Linux Mint 14, Photoshop CS 2 in Wine has been unreliable.

It ran a couple times after my first install, but now it has settled into never running, and instead, it just returns an error saying "File not found".

file not found

I tried re-installing, and also installing into a custom directory, but that hasn't helped. I tried restarting the Wine server with wineserver -k, and rebooting, but neither helped.

I get the same error if I try to run Photoshop.exe from the command line, even if I'm in the directory where the file is and I can see it listed when I run an ls command. So I don't think this is a matter of the Photoshop.exe file not being found, it is some system file or Wine setting.

How can I get past this error and have Photoshop running consistently?

3

Thanks to help on the Linux Mint forum, a workable solution has been found.

That solution is to install Photoshop using playonlinux. I don't exactly know what playonlinux does to make Wine work better, but it seems to do the trick.

I uninstalled Photoshop first, installed playonlinux in Synaptic, and then re-installed Photoshop by opening playonlinx and following the steps it provided.

0
0

I know this thread is old as heck, but just in case anyone stumbles upon this in the future, I found that the solution is a lot simpler than you may have thought.

Just edit the Photoshop .desktop file to use this command:

wine "/home/‹your username>/.wine/drive_c/Program Files/Adobe/Adobe Photoshop CS6 (64 Bit)/Photoshop.exe"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.