0

I have mounted dropbox using rclone to /home/user/Dropbox. I'm using rsync to upload the files to dropbox. I have done so around 400GB just using this method.

dropbox capacity

Today however it uploaded some files and stopped with the summary of the tranfer (no errors) like it has completed tranferring all the files.

However, when I check the source directories, there are some files left. Since I'm using --append and --remove-source-files flags, there shouldn't be any files left.

I tried to copy one of them using file manager and it shows that the file already exists at the targed and prompt to replace.

Following is the command I used.

❯ rsync \
-var \
--append-verify \
--remove-source-files \
/media/s1n7ax/92802CA0802C8CB3/Digikam/ \
/home/s1n7ax/Dropbox/Camera\ Album/
sending incremental file list
./
2022-07-23 Wewathenna/
2022-07-23 Wewathenna/Raw/
2022-10-16 Dolukanda/
2022-10-16 Dolukanda/Edited/
2022-10-16 Dolukanda/Raw/
2022-10-16 Dolukanda/Udul's Photos/
2022-11-06 Nuwara Eliya/
2022-11-06 Nuwara Eliya/Raw/
2022-11-20 Peradeniya Botanical Garden/
2022-11-20 Peradeniya Botanical Garden/Raw/
2022-12-13 Pinnawala/
2022-12-13 Pinnawala/Raw/
2023-01-21 Riverston/
2023-01-21 Riverston/Anura's Photos/
2023-03-25 Gatemore/
2023-03-25 Gatemore/Raw/
2023-04-08 Kanawiddagala/
2023-04-08 Kanawiddagala/Raw/

sent 36,726 bytes  received 153 bytes  1,715.30 bytes/sec
total size is 121,892,420,904  speedup is 3,305,198.65

I tried to copy a directory that only contains files too.

❯ rsync \
-var \
--append-verify \
--remove-source-files \
/media/s1n7ax/92802CA0802C8CB3/Digikam/2022-07-23\ Wewathenna/Raw/ \
/home/s1n7ax/Dropbox/Camera\ Album/2022-07-23\ Wewathenna/Raw/
sending incremental file list
./

sent 505 bytes  received 19 bytes  1,048.00 bytes/sec
total size is 1,316,281,020  speedup is 2,511,986.68

Details of one file

Source:

ls -l 1Y3A8976.CR3
-rwxrwxrwx 1 s1n7ax s1n7ax 50107478 Jul 23  2022 1Y3A8976.CR3

Target:

ls -l 1Y3A8976.CR3
-rw-rw-r-- 1 s1n7ax s1n7ax 50107478 Jun 29 20:56 1Y3A8976.CR3

1 Answer 1

3

I don't see anything in the manual about it, but it appears --append/--append-verify ignore files that are newer on the destination (which is true for your example).

Basically, it seems like append implies --update.

It doesn't explain how you got into this situation, but it does explain why your current invocation isn't cleaning it up.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .